RFLink 868 in Domoticz op RPI3

Dutch support forum, post can be done in Dutch
Je mag hier in het Nederlands posten!

Moderators: Voyager, BertB, rtenklooster, Stuntteam

Post Reply
Message
Author
bram82
Normal user
Posts: 3
Joined: 03 Mar 2018, 15:10

RFLink 868 in Domoticz op RPI3

#1 Post by bram82 » 03 Mar 2018, 15:28

Vandaag heb ik mijn werkende RFLink 433 Mhz vervangen door een compleet nieuwe 868 Mhz versie. Ik heb de firmware op de oude Arduino geupdate naar de laatste versie R48. Het log van Domoticz ziet er in de eerste instantie goed uit:

2017-11-07 19:02:19.735 RFLink: Using serial port: /dev/ttyACM0
2017-11-07 19:02:20.541 Python EventSystem: Module not found - Trying to initialize.
2017-11-07 19:02:20.565 Python EventSystem: Initalizing event module.
2017-11-07 19:02:20.566 EventSystem: Started
2017-11-07 19:02:20.649 RFLink: 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
2017-11-07 19:02:20.649 RFLink: Controller Initialized!...
2017-11-07 19:02:20.725 RFLink: 20;01;VER=1.1;REV=48;BUILD=04;
2017-11-07 19:02:20.725 RFLink Detected, Version: 1.1 Revision: 48 Build: 4
2017-11-07 19:03:20.527 RFLink: 20;02;PONG;

Ik wil nu mijn Smanos alarmsysteem toevoegen (deze wordt ondersteund door RFLink), maar de RFLink detecteert geen apparaten. Nou ja, één keer heeft het gewerkt. Toen werden er op de RPI ineens wel apparaten gedetecteerd, maar ik kan het niet herhalen.

Als ik de RFLink aansluit op de PC en voeg het daar toe aan Domoticz onder Windows 10 worden er wel apparaten gedetecteerd:

2017-11-07 19:38:15.661 RFLink Detected, Version: 1.1 Revision: 48 Build: 4
2017-11-07 19:38:15.710 OTGW: Using serial port: /dev/ttyUSB0
2017-11-07 19:38:44.208 (RFLink) Light/Switch (Unknown)
2017-11-07 19:38:52.900 (RFLink) Light/Switch (Unknown)
2017-11-07 19:38:57.616 (RFLink) Light/Switch (Unknown)


Ook in het RFloader programma in de firmware zip zie ik goede logs:

20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
10;version;
20;01;VER=1.1;REV=48;BUILD=04;
10;status;
20;02;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
20;03;Chuango;ID=8f0d0b;SWITCH=02;CMD=ON;
20;04;Chuango;ID=f11729;SWITCH=02;CMD=ON;
20;05;V2Phoenix;ID=0600506;SWITCH=02;CMD=ON;
20;06;TRC02RGB;ID=ffffff;SWITCH=ff;RGBW=ff00;CMD=COLOR;
20;07;Slave;Debug=7d 1e 78 1c f4 -8191;
20;08;Chuango;ID=8f0d0e;SWITCH=02;CMD=OFF;


Wat is het probleem???

User avatar
Stuntteam
Site Beheer
Posts: 578
Joined: 27 Jan 2016, 16:46

Re: RFLink 868 in Domoticz op RPI3

#2 Post by Stuntteam » 03 Mar 2018, 20:04

Het lijkt erop dat je een boel storing ontvangt. De 868mhz ontvanger is een stuk gevoeliger. Zorg dat het geheel niet te dicht bij een power supply staat en dat de afstand tot de Pi niet te kort is.
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

bram82
Normal user
Posts: 3
Joined: 03 Mar 2018, 15:10

Re: RFLink 868 in Domoticz op RPI3

#3 Post by bram82 » 04 Mar 2018, 20:20

Een langere kabel mag helaas niet helpen.

Op de RPI krijg ik ook niet de melding in het log "RFLink Detected", zoals ik die op de PC wel krijg.

De enige log die ik krijg is: "2018-03-04 19:53:40.666 RFLink: Using serial port: /dev/ttyACM0" en dan houdt het op...

User avatar
Stuntteam
Site Beheer
Posts: 578
Joined: 27 Jan 2016, 16:46

Re: RFLink 868 in Domoticz op RPI3

#4 Post by Stuntteam » 05 Mar 2018, 00:17

Volgens mij moet je wel meer zien.. lijkt op een probleem met de usb poort.
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

bram82
Normal user
Posts: 3
Joined: 03 Mar 2018, 15:10

Re: RFLink 868 in Domoticz op RPI3

#5 Post by bram82 » 06 Mar 2018, 18:46

Ik ben weer iets verder. Ik heb de rflink nu een aantal dagen aangesloten gehouden en opeens komen er sinds vandaag allerlei apparaten binnenlopen. Het vreemde is dat ik het smanos alarmsysteem niet krijg toegevoegd. Dit terwijl dit eerder dus wel lukte. Ik kon toen eenmalig zowel bewegings als deur sensoren toevoegen.

Het log van domoticz:

2018-03-06 17:48:36.156 (RFLink 868) Temp (BL999)
2018-03-06 17:48:41.988 (RFLink 868) Light/Switch (Unknown)
2018-03-06 17:51:04.690 (RFLink 868) Light/Switch (Unknown)
2018-03-06 17:54:28.236 (RFLink 868) Temp + Humidity (Alecto V1)
2018-03-06 17:56:26.169 (RFLink 868) Temp + Humidity (BL999)
2018-03-06 17:56:52.705 (RFLink 868) Lighting Limitless/Applamp (TRC02RGB)
2018-03-06 18:06:00.386 (RFLink 868) Temp + Humidity (Alecto V1)
2018-03-06 18:07:17.134 (RFLink 868) Temp + Humidity (Alecto V1)
2018-03-06 18:09:50.677 (RFLink 868) Light/Switch (Unknown)
2018-03-06 18:11:42.751 (RFLink 868) Temp + Humidity (Alecto V1)
2018-03-06 18:11:46.439 (RFLink 868) Light/Switch (Unknown)
2018-03-06 18:11:53.292 (RFLink 868) Light/Switch (Unknown)
2018-03-06 18:12:53.528 Error: RFLink: Unhandled switch type: Astrell
2018-03-06 18:15:44.814 (RFLink 868) Light/Switch (Unknown)
2018-03-06 18:16:10.464 (RFLink 868) Light/Switch (Unknown)
2018-03-06 18:20:43.853 (RFLink 868) Temp (BL999)
2018-03-06 18:21:05.694 (RFLink 868) Temp (BL999)


Maar niks in de logo's als een deursensor of bewegings sensor of de afstandsbediening een signaal uitstuurt....?.?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests