Cant connect after update mega-20180822

Moderators: Voyager, BertB, rtenklooster, Stuntteam, grovkillen, TD-er

Post Reply
Message
Author
ILoveIOT
Normal user
Posts: 43
Joined: 01 Nov 2015, 10:54

Cant connect after update mega-20180822

#1 Post by ILoveIOT » 04 Sep 2018, 16:35

Hi,

Just wanna inform you that I cannot connect with Wemos D1 Mini after update 20180822, get the error

Disconnected! Reason: '(201) No AP found' Connected for 2860

Cant connect to any network, but can scan and see the networks, also the local espconfig network does not show up (APmode)

Unit 0
Uptime 0 days 0 hours 6 minutes
Load 4.30% (LC=16686)
Free Mem 20568 (19200 - sendContentBlocking)
Boot Manual reboot (17)
Reset Reason External System
Network ❔
Wifi 802.11N (RSSI -65 dB)
IP config DHCP
IP / subnet 192.168.50.231 / 255.255.255.0
GW 192.168.50.1
Client IP 192.168.50.199
DNS 0.0.0.0 / 0.0.0.0
Allowed IP Range 192.168.50.0 - 192.168.50.255
Serial Port available: 1 (128 , 0)
STA MAC 5C:CF:7F:B5:5B:A7
AP MAC 5E:CF:7F:B5:5B:A7
SSID wifinetwork (00:E0:4C:08:F5:29)
Channel 1
Connected 6 m 11 s
Last Disconnect Reason (1) Unspecified
Number reconnects 0
Firmware
Build 20102 - Mega
Libraries ESP82xx Core 00000000, NONOS SDK 2.2.1(cfd48f3), LWIP: 2.0.3
GIT version mega-20180818
Plugins 48 [Normal]
Build Md5 9c6a619c208875e9a75cf46a252a8276
Md5 check passed.
Build time Aug 18 2018 02:14:17
Binary filename ESP_Easy_mega-20180818_normal_ESP8266_4096.bin
ESP board
ESP Chip ID 11885479 (0xB55BA7)
ESP Chip Freq: 80 MHz
Storage
Flash Chip ID Vendor: 0xC8 Device: 0x4016
Flash Chip Real Size: 4096 kB
Flash IDE Size: 4096 kB
Flash IDE speed: 40 MHz
Flash IDE mode: DIO
Flash Writes 16 daily / 16 boot
Sketch Size 719 kB (2352 kB free)

TD-er
Normal user
Posts: 1154
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Cant connect after update mega-20180822

#2 Post by TD-er » 04 Sep 2018, 20:21

Hmm this looks strange, your DNS is set to 0.0.0.0 and it reports an IP-address, but also stating it is using DHCP.

What was the version used before this one?

ILoveIOT
Normal user
Posts: 43
Joined: 01 Nov 2015, 10:54

Re: Cant connect after update mega-20180822

#3 Post by ILoveIOT » 05 Sep 2018, 15:55

Hmm this looks strange, your DNS is set to 0.0.0.0 and it reports an IP-address, but also stating it is using DHCP.
Yes a bit strange but DNS is not used, so should not be a problem, dhcp gives the same IP as the later manual inserted IP address.
What was the version used before this one?
Version mega-20180818 works fine as you can see, problem begin after update 20180822, version before the mega was ESPEasy_v2.0.0-dev12.

He just cant connect to the wifi acesspoint at all, ip address, dns, etc is much later.

TD-er
Normal user
Posts: 1154
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Cant connect after update mega-20180822

#4 Post by TD-er » 05 Sep 2018, 22:09

Have you als tried a later build, just to make sure it isn't a build issue (compile/link issue at the nightly builds)

ILoveIOT
Normal user
Posts: 43
Joined: 01 Nov 2015, 10:54

Re: Cant connect after update mega-20180822

#5 Post by ILoveIOT » 06 Sep 2018, 11:09

Oh,..Yeah first the latest, found the problem, and worked my way down, as you can see after 16 firmware versions that day, I found out that the problem exist from version mega-20180822.

Found the module on the internet back..

NodeMCU V3 Lua WIFI Module ESP8266+Extra Memory 32M Flash USB-Serial CH340G
https://www.ebay.com/itm/NodeMCU-V3-Lua ... 2443598791

Image

TD-er
Normal user
Posts: 1154
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Cant connect after update mega-20180822

#6 Post by TD-er » 06 Sep 2018, 20:09

I was just reading through this thread and in the first post you mention a Wemos D1 mini and now this one.
Are there more boards with this problem?

The thing is, I do test all builds myself on some nodes.
I won't be surprised if the one on my breadboard has had > 1000 versions.
And here no issues with the wifi.

Do you happen to know the wifi settings of your router/accesspoint?
I have had another issue where someone recently reported his problems were gone after changing the channel settings to 20 MHz bandwidth instead of 40 MHz.

xury
Normal user
Posts: 31
Joined: 02 Apr 2018, 12:54

Re: Cant connect after update mega-20180822

#7 Post by xury » 06 Sep 2018, 22:43

I had the same issue two months ago with the exactly same hardware.
I don't remember what exactly was a espeasy version.
After i tried reflash with another versions and still did not connected.
Finally I flash whole flash area with blank 4mb file and next with firmware what previously was not connect and it starting connect well.
So I letting you to try:
flash whole flash area wit FF filed blank file.
Reflash same version and check.

ILoveIOT
Normal user
Posts: 43
Joined: 01 Nov 2015, 10:54

Re: Cant connect after update mega-20180822

#8 Post by ILoveIOT » 07 Sep 2018, 12:20

I was just reading through this thread and in the first post you mention a Wemos D1 mini and now this one.
Are there more boards with this problem?
No the problem that I found was only this board, was thinking this is a Wemos D1 board (but clearly not), but now I'am 100% sure, where thinking about the same board ;)
Finally I flash whole flash area with blank 4mb file and next with firmware what previously was not connect and it starting connect well.
So I letting you to try: flash whole flash area wit FF filed blank file.
Thank you for you're solution, I guess this will solve it (you had the same issue), because there is only a memory difference, problem is module is back into the field, and is the only one I have, due space problems cannot swap it for a normal one (normal MCUv3 are 2mm longer), when I have it back in my hands I will check it.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 2 guests