values in device tab not changing?

Moderators: Voyager, BertB, rtenklooster, Stuntteam, Martinus, grovkillen, TD-er

Post Reply
Message
Author
kenkoknz
Normal user
Posts: 33
Joined: 03 Jul 2018, 23:46
Location: New Zealand

values in device tab not changing?

#1 Post by kenkoknz » 14 Sep 2018, 00:45

Hi
hw:nodemcu v3
fw: GIT version: mega-20180903

Setup: simple mqtt topic to turn on blue led in nodemcu. Works good, I can send a mqtt topic to turn the led on or off, but on the GUI config under device tab, the value(green field) stay at "1" and does not change, yet every thing seems to work.:
log
93348972: EVENT: temp#Humidity=42.30
93350536: SW : GPIO 2 Set to 1
93356535: SW : GPIO 2 Set to 0

device config is just switch, normal with pull up.

Have also refresh the browser, still same, is the status show in the device tab real time?

Thanks,
Ken

User avatar
grovkillen
Normal user
Posts: 1897
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: values in device tab not changing?

#2 Post by grovkillen » 14 Sep 2018, 11:50

The device page is in deed "real time" but the browser only knows when to update reoccurring events (sensors etc) values. A valve or a switch for example is no periodically devices and this it do not know when to check for a update.

BUT if you have a sensor that is updating its value lets say once per second the device list will of course update the valve or switch value.
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Sponsor ESP Easy, we need you :idea: :idea: :idea:

wim16
Normal user
Posts: 74
Joined: 01 May 2017, 20:35

Re: values in device tab not changing?

#3 Post by wim16 » 14 Sep 2018, 12:36


Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests