RPIEasy

Moderators: Voyager, BertB, rtenklooster, Stuntteam, grovkillen, TD-er

Message
Author
User avatar
enesbcs
Normal user
Posts: 287
Joined: 18 Jun 2017, 11:02
Location: Békéscsaba, Hungary
Contact:

Re: RPIEasy

#51 Post by enesbcs » 11 Jan 2019, 18:19

iron wrote:
11 Jan 2019, 10:17
I am having difficulty uploading the MQTT cert file via the <ip>/filelist page. I can upload a .jpg and a .txt but not the TLS.pem, file even after I renamed it to TLS.txt
I'm opened /filelist just now from RPIEasy hosted by a Raspberry Pi Zero W.
(As browser i used a Firefox v63.0 on a desktop Ubuntu Linux OS.)
Clicked to Upload, browsed a "TLS.pem" file (~1.5kb size) from my desktop, clicked Upload, and TLS.pem appeared at the RPIEasy files/ directory with no problem.
To investigate it, please feel free to open a new issue at the github.
1. Update your RPIEasy from Github
2. Set Tools->Advanced->Web Log level to "Debug"
3. Retry uploading the problematic file and post the logs. (Also describe details about the OS, browser, complete path name of the file on your system, and attach the problematic file if possible)

User avatar
iron
Normal user
Posts: 58
Joined: 24 Sep 2016, 08:37
Location: Veria, Greece
Contact:

Re: RPIEasy

#52 Post by iron » 11 Jan 2019, 19:16

enesbcs wrote:
11 Jan 2019, 18:19
iron wrote:
11 Jan 2019, 10:17
I am having difficulty uploading the MQTT cert file via the <ip>/filelist page. I can upload a .jpg and a .txt but not the TLS.pem, file even after I renamed it to TLS.txt
I'm opened /filelist just now from RPIEasy hosted by a Raspberry Pi Zero W.
(As browser i used a Firefox v63.0 on a desktop Ubuntu Linux OS.)
Clicked to Upload, browsed a "TLS.pem" file (~1.5kb size) from my desktop, clicked Upload, and TLS.pem appeared at the RPIEasy files/ directory with no problem.
To investigate it, please feel free to open a new issue at the github.
1. Update your RPIEasy from Github
2. Set Tools->Advanced->Web Log level to "Debug"
3. Retry uploading the problematic file and post the logs. (Also describe details about the OS, browser, complete path name of the file on your system, and attach the problematic file if possible)
FF "solved" the upload issue (Chrome still doesn't)

Connected to :

mqtt.gbridge.kappelt.net
MQTT server: mqtt.gbridge.kappelt.net
MQTT port: 8883
MQTT protocol: Version 3.1
TLS: TLS V1.2

MQTT.fx connects to it

Device log shows disconnects

19:36:06 Event: GenMQTT#Connected
19:36:06 Event: GenMQTT#Disconnected

-D
-D

User avatar
enesbcs
Normal user
Posts: 287
Joined: 18 Jun 2017, 11:02
Location: Békéscsaba, Hungary
Contact:

Re: RPIEasy

#53 Post by enesbcs » 11 Jan 2019, 21:11

iron wrote:
11 Jan 2019, 19:16
FF "solved" the upload issue (Chrome still doesn't)
Thank you for this information I can reproduce this bug with Chrome, and created a new issue for it.
iron wrote:
11 Jan 2019, 19:16
Connected to :

mqtt.gbridge.kappelt.net
MQTT server: mqtt.gbridge.kappelt.net
MQTT port: 8883
MQTT protocol: Version 3.1
TLS: TLS V1.2

MQTT.fx connects to it

Device log shows disconnects

19:36:06 Event: GenMQTT#Connected
19:36:06 Event: GenMQTT#Disconnected
I've used http://test.mosquitto.org/ for testing, but will try kappelt.net.

UDPATE: Refresh from Github then clear and readd you Controller Password, then Submit. I think issue will be fixed now.

User avatar
budman1758
Normal user
Posts: 208
Joined: 15 Apr 2017, 05:13
Location: Riverside CA USA

Re: RPIEasy

#54 Post by budman1758 » 12 Jan 2019, 19:47

This is a request for update instructions to add to the readme in the Git page. I have been using "git-pull" and then rebooting the Pi. Was wondering if there is an easier way to update without rebooting the PI. My be helpful for all users. Thanks. :D

Perhaps an update mechanism in the tools page? Should I make a Git issue?
"The glass is twice as big as it needs to be".

User avatar
enesbcs
Normal user
Posts: 287
Joined: 18 Jun 2017, 11:02
Location: Békéscsaba, Hungary
Contact:

Re: RPIEasy

#55 Post by enesbcs » 12 Jan 2019, 20:29

budman1758 wrote:
12 Jan 2019, 19:47
This is a request for update instructions to add to the readme in the Git page. I have been using "git-pull" and then rebooting the Pi. Was wondering if there is an easier way to update without rebooting the PI. My be helpful for all users. Thanks. :D

Perhaps an update mechanism in the tools page? Should I make a Git issue?
If you are using the run.sh startup script (if "RPIEasy autostart at boot" checked, than run.sh is used for sure) then you can use "Tools->Exit"... after "git-pull". This way RPIEasy stopping itself, but run.sh kicks it back, so in fact it is not an exit, but a restart without rebooting the Pi. :)
Issue for some kind of update mechanism can be add, but will be tagged as "ETA: Next stable release", this is still a beta.

User avatar
iron
Normal user
Posts: 58
Joined: 24 Sep 2016, 08:37
Location: Veria, Greece
Contact:

Re: RPIEasy

#56 Post by iron » 14 Jan 2019, 18:36

enesbcs wrote:
11 Jan 2019, 21:11
iron wrote:
11 Jan 2019, 19:16
FF "solved" the upload issue (Chrome still doesn't)
Thank you for this information I can reproduce this bug with Chrome, and created a new issue for it.
iron wrote:
11 Jan 2019, 19:16
Connected to :

mqtt.gbridge.kappelt.net
MQTT server: mqtt.gbridge.kappelt.net
MQTT port: 8883
MQTT protocol: Version 3.1
TLS: TLS V1.2

MQTT.fx connects to it

Device log shows disconnects

19:36:06 Event: GenMQTT#Connected
19:36:06 Event: GenMQTT#Disconnected
I've used http://test.mosquitto.org/ for testing, but will try kappelt.net.

UDPATE: Refresh from Github then clear and readd you Controller Password, then Submit. I think issue will be fixed now.
I could never connect to kappelt.

I just connected to cloudMQTT without security and I can publish / subscribe.

Yet in the log :

19:32:01 Event: GenMQTT#Connected
19:32:07 Unit alive: 3
19:32:07 Unit alive: 3
19:32:07 Unit alive: 3
19:32:14 Unit alive: 1
19:32:14 Unit alive: 1
19:32:14 Unit alive: 1
19:32:26 Unit alive: 2
19:32:26 Unit alive: 2
19:32:26 Unit alive: 2
19:32:26 MQTT connection error: 5

Although I am connected to cloudMQTT !!!

-D
-D

User avatar
enesbcs
Normal user
Posts: 287
Joined: 18 Jun 2017, 11:02
Location: Békéscsaba, Hungary
Contact:

Re: RPIEasy

#57 Post by enesbcs » 14 Jan 2019, 21:53

iron wrote:
14 Jan 2019, 18:36
Yet in the log :

19:32:01 Event: GenMQTT#Connected
19:32:07 Unit alive: 3
19:32:07 Unit alive: 3
19:32:07 Unit alive: 3
19:32:14 Unit alive: 1
19:32:14 Unit alive: 1
19:32:14 Unit alive: 1
19:32:26 Unit alive: 2
19:32:26 Unit alive: 2
19:32:26 Unit alive: 2
19:32:26 MQTT connection error: 5

Although I am connected to cloudMQTT !!!

-D
I've found a possible solution: MQTT servers do not like if password supplied after connect(). I applied a new variable to sign if password already applied and reverted back from connect_async() to simple blocking connect() method to make sure that disconnect will not arrive sooner than connect.

FYI: I can use cloudMQTT and kappelt.net MQTT servers without any problem.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 5 guests