Compiler error with latest release.

Moderators: Voyager, BertB, rtenklooster, Stuntteam, grovkillen, TD-er

Post Reply
Message
Author
EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Compiler error with latest release.

#1 Post by EddyG » 08 Jan 2019, 13:08

I am using Arduine IDE 1.8.8
The clean install of version "ESPEasy_mega-20181220" compiles fine. (And all previous versions did)
The clean install of version "ESPEasy_mega-20190108" gives errors.
The offending code is in ESPEasy-Globals.h

Code: Select all

String getUnknownString();
and in "Misc.ino"

Code: Select all

String getUnknownString() { return F("Unknown"); }
How can I solve that? If I uncomment one or the other I get other compile errors.

The compile errors started with the switch from "ESPEasySoftwareSerial" to "ESPEasySerial" because "ESPEasy_mega-20181231" complies fine too.

EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Re: Compiler error with latest release.

#2 Post by EddyG » 08 Jan 2019, 17:49

The "static" in ESPEasy-Globals.h solved the error, but now I get other errors in the Arduino IDE.

Code: Select all

_Plugin_Helper_serial:3:47: error: 'ESPeasySerialType' has not been declared

 static String serialHelper_getSerialTypeLabel(ESPeasySerialType::serialtype serType) {

                                               ^

_Plugin_Helper_serial:30:1: error: 'ESPeasySerialType' does not name a type

 ESPeasySerialType::serialtype serialHelper_getSerialType(struct EventStruct *event) {

 ^

C:\Users\Eddy\Documents\Arduino\ESPEasy\_Plugin_Helper_serial.ino: In function 'String serialHelper_getSerialTypeLabel(ESPeasySerialType::serialtype)':

_Plugin_Helper_serial:3:84: error: 'String serialHelper_getSerialTypeLabel(ESPeasySerialType::serialtype)' redeclared as different kind of symbol

 static String serialHelper_getSerialTypeLabel(ESPeasySerialType::serialtype serType) {

                                                                                    ^

_Plugin_Helper_serial:3:15: error: previous declaration of 'String serialHelper_getSerialTypeLabel'

 static String serialHelper_getSerialTypeLabel(ESPeasySerialType::serialtype serType) {

               ^

C:\Users\Eddy\Documents\Arduino\ESPEasy\_Plugin_Helper_serial.ino: In function 'void serialHelper_webformLoad(EventStruct*)':

_Plugin_Helper_serial:49:55: error: no match for call to '(String) (ESPeasySerialType::serialtype&)'

       option = serialHelper_getSerialTypeLabel(serType);

                                                       ^

Multiple libraries were found for "Servo.h"
 Used: C:\Users\Eddy\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\libraries\Servo
 Not used: C:\Program Files (x86)\Arduino\libraries\Servo
exit status 1
'ESPeasySerialType' has not been declared
Hope that can be solved too.
Last edited by EddyG on 08 Jan 2019, 19:29, edited 1 time in total.

User avatar
grovkillen
Normal user
Posts: 2828
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Compiler error with latest release.

#3 Post by grovkillen » 08 Jan 2019, 18:12

Have you downloaded today's code base? TD-er applied a fix...
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Re: Compiler error with latest release.

#4 Post by EddyG » 08 Jan 2019, 19:36

I saw on GitHub what the little change in "ESPEasy-Globals.h"was (static) and I applied that manually.
So the first error is gone, but I got other errors back. See above.

User avatar
grovkillen
Normal user
Posts: 2828
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Compiler error with latest release.

#5 Post by grovkillen » 08 Jan 2019, 20:04

Ok, we're officially using PlatformIO on Atom. Sorry for not being able to help more.
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Re: Compiler error with latest release.

#6 Post by EddyG » 08 Jan 2019, 21:17

Pitty, but I still hope that TD-er can solve this error too.

ltrpv
Normal user
Posts: 1
Joined: 08 Jan 2019, 23:55

Re: Compiler error with latest release.

#7 Post by ltrpv » 09 Jan 2019, 00:59

I managed to work-around this issue by including the espeasyserial.h in the global.h, so it gets included sooner. Probably a dependency-loop somewhere.

EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Re: Compiler error with latest release.

#8 Post by EddyG » 09 Jan 2019, 14:06

Could you tell where you included the ESPeasySerial.h
Because I included it but got other errors instead.

EddyG
Normal user
Posts: 19
Joined: 05 Sep 2018, 16:03

Re: Compiler error with latest release.

#9 Post by EddyG » 09 Jan 2019, 14:22

Found it!
I include the ESPeasySerial.h at the end of my Custom.h
That did the trick.

pitrio
Normal user
Posts: 17
Joined: 23 Apr 2018, 16:49

Re: Compiler error with latest release.

#10 Post by pitrio » 10 Jan 2019, 15:39

dear all,
I also have the same problem during compile Espeasy with Arduino IDE.
thank you in advance if you can solve it!

ricc

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests