Search found 6 matches

by antikiller_bm
24 Jan 2019, 16:59
Forum: ESP Easy: General Discussion
Topic: Can't compile with a new plugin (PZEM004T)
Replies: 22
Views: 3734

Re: Can't compile with a new plugin (PZEM004T)

Yes, it is a real hardware serial. But if I only changing GPiO in device settings, i have just software serial over gpio 3/1. Of course it does not work this way:lol:
by antikiller_bm
23 Jan 2019, 19:25
Forum: ESP Easy: General Discussion
Topic: Can't compile with a new plugin (PZEM004T)
Replies: 22
Views: 3734

Re: Can't compile with a new plugin (PZEM004T)

Finnaly Ive beat it
Just replace pzemTXpin and pzemRXpin with hardware pins 3,1 in the plugin code.
by antikiller_bm
22 Jan 2019, 12:13
Forum: ESP Easy: General Discussion
Topic: Can't compile with a new plugin (PZEM004T)
Replies: 22
Views: 3734

Re: Can't compile with a new plugin (PZEM004T)

I have a lot of warnings due compiling, but it always finished succesfully
May you give me the binary just to make sure? Im using ESP12E 4mb
Thx

Nothing changed after setting up debug
by antikiller_bm
22 Jan 2019, 09:04
Forum: ESP Easy: General Discussion
Topic: Can't compile with a new plugin (PZEM004T)
Replies: 22
Views: 3734

Re: Can't compile with a new plugin (PZEM004T)

Still not working. With the new library even log show nothing I have checkd hardware again with Atmega 328p (same library for arduino) and esp12 with wi-fi_iot firmware. Both are working fine. But when I change firmware to ESPEasy - I still have always 0.00V Last try i just checked answer from PZEM ...
by antikiller_bm
17 Jan 2019, 21:21
Forum: ESP Easy: Hardware
Topic: Support for PZEM 004T Energy monitor
Replies: 142
Views: 54970

Re: Support for PZEM 004T Energy monitor

I also have some problem with building this project I have two builds ESPEasy_mega-20181231 and latest with changed Softwareserial library ESPEasy_mega-20181231 compiles without error only if espsoftwareserial-3.2.3 used 20190110 compiles with new ESPEasySerial library also without any errors But bo...
by antikiller_bm
17 Jan 2019, 08:04
Forum: ESP Easy: General Discussion
Topic: Can't compile with a new plugin (PZEM004T)
Replies: 22
Views: 3734

Re: Can't compile with a new plugin (PZEM004T)

I also have some problems with building this project @goldriver In the PZEM004T library folder, in library.json remove the dependancy to EspSoftwareSerial : Its helps me to compile firmware without any errors, but my pzem just not working. I always see 0.0 I think that is not a hardware problem, wif...