Search found 32 matches

by schnurzel59
13 May 2019, 15:16
Forum: ESP Easy: General Discussion
Topic: How do i make the TaskValueSet of a dummy device persist after reboot
Replies: 6
Views: 1060

Re: How do i make the TaskValueSet of a dummy device persist after reboot

Hi, I solved it that way for me. Repeated watchdog reboots permanently delete all shutter positions. I use a Raspbery (I use Raspberymatic for other tasks. the ESP controls "only" the shutters.) and send my data to the controller. After a reboot of the ESP, the Pi receives a message and sends all da...
by schnurzel59
03 May 2019, 11:02
Forum: ESP Easy: General Discussion
Topic: How to remote manipulate dummy device value?
Replies: 4
Views: 459

Re: How to remote manipulate dummy device value?

I am very happy that you are happy.
by schnurzel59
02 May 2019, 11:45
Forum: ESP Easy: General Discussion
Topic: How to remote manipulate dummy device value?
Replies: 4
Views: 459

Re: How to remote manipulate dummy device value?

Hello Steve,

In a Browser:

Code: Select all

http://192.168.100.50/control?cmd=taskvalueset,X,1,YYY.Y
http://192.168.100.50/control?cmd=taskvalueset,X,2,YYY.Y
X is the Devicenumber.(1 to 12)
YYY,Y is the new Value.

Greetings
Martin
by schnurzel59
28 Apr 2019, 11:54
Forum: ESP Easy: Software
Topic: (solved - user error) sendto sendhttp no eventvalue data send
Replies: 2
Views: 233

Re: sendto sendhttp no eventvalue data send

Hi, Your information is a bit short. If you do not have a solution, you should describe a few more things. "ACT: sendTo 149, event, disp_kt =" shows that your "[esp01_178_Temp # esp01_178_Temp]" must be incorrect. Otherwise there would have to be a value after "... disp_kt =". Why "SendToHTTP"? "Sen...
by schnurzel59
13 Apr 2019, 21:29
Forum: ESP Easy: Software
Topic: Issue in Rules and sendtohttp
Replies: 11
Views: 637

Re: Issue in Rules and sendtohttp

obviously the "-" in "upnp-org" is a problem. I have replaced it for testing by the ASCII character in percentage representation "%2D". I do not know if that works, because I do not have a vera controller. Then the string is not shared at this point. SendToHTTP 192.168.3.109,3480,/data_request?id=va...
by schnurzel59
12 Apr 2019, 01:35
Forum: RFlink: General Discussions
Topic: So many questions and no answers ? the forum is dead or not ?
Replies: 3
Views: 627

Re: So many questions and no answers ? the forum is dead or not ?

why so many questions and no answers ? Hi, if you would like to see how many people have read your posts, then you would notice that this forum is not dead. It just does not feel like answering questions of this kind. I have something that does not work the way I want it. Now everyone should be obl...
by schnurzel59
01 Apr 2019, 23:41
Forum: ESP Easy: Projects / Applications
Topic: Relay
Replies: 8
Views: 761

Re: Relay

Hi Ro_64 It would be easier to help if you had an idea of what you want to do. What is bo # bo? A switch? When is the condition = "0" given? hum # hum is the water level. OK.What does your relay do? A little more detail would be helpful. Your switch rele is labeled wrong. On the one picture it has t...
by schnurzel59
31 Mar 2019, 18:47
Forum: ESP Easy: Software
Topic: Incorrect pin state in GPIO command status report?
Replies: 1
Views: 191

Re: Incorrect pin state in GPIO command status report?

Hello,
just tested:

Code: Select all

Gpio 0 is OFF

Gpio,0,1

Gpio 0 is now ON.  The State is "0"

Again: Gpio,0,1

Now the State is "1"
The same result I do have when switching to 0.
Probably "state" shows the state before the switching process.
by schnurzel59
28 Mar 2019, 22:20
Forum: ESP Easy: Software
Topic: New Reboot Cause. What's this?
Replies: 4
Views: 480

Re: New Reboot Cause. What's this?

Thank You,
by schnurzel59
28 Mar 2019, 22:18
Forum: ESP Easy: Software
Topic: Reboot, Soft- or Hardware-Problem. My Solution
Replies: 2
Views: 318

Re: Reboot, Soft- or Hardware-Problem. My Solution

Hi, in the next days I will connect my memory oscilloscope to look at the supply voltage. Although the power source should deliver 25W, but that's always only information from the manufacturer. Voltage dips are always possible. I actually see that as the most obvious cause. Now all I have to do is c...
by schnurzel59
28 Mar 2019, 21:57
Forum: ESP Easy: Software
Topic: Flash ESPEasy with Arduino IDE -> Missing Library
Replies: 10
Views: 1888

Re: Flash ESPEasy with Arduino IDE -> Missing Library

Thank you. As you said, starting with "PlatformIO" is a challenge. Yes. You have to look a little deeper into the system to see all the possibilities. So again a big change for me. But a compiler run without warnings and mistakes compensates for everything. Now I can finally flash my ESP according t...
by schnurzel59
28 Mar 2019, 10:05
Forum: ESP Easy: Software
Topic: Flash ESPEasy with Arduino IDE -> Missing Library
Replies: 10
Views: 1888

Re: Flash ESPEasy with Arduino IDE -> Missing Library

Hi Thomas B,I tried now. PlatformIO has made sure that the last gray hair has turned white now. After I had pushed all the files into the correct folder, it ran on the first attempt to this result. But see the following picture. "SUCCESS". Pictures say more than words. PlatformIO.jpg It would only b...
by schnurzel59
27 Mar 2019, 01:44
Forum: ESP Easy: Software
Topic: New Reboot Cause. What's this?
Replies: 4
Views: 480

Re: New Reboot Cause. What's this?

Hi, "New" is for me only the reason of the reboot. And the Free Memory and the Free Stack Comments: "sendContentBlocking" and "parseTemplate3" I control 3 shutters. This happens depending on time and temperature. All calculations are done externally in my homematic. Only commands are sent to the ESP...
by schnurzel59
24 Mar 2019, 23:44
Forum: ESP Easy: Software
Topic: New Reboot Cause. What's this?
Replies: 4
Views: 480

New Reboot Cause. What's this?

Hello,
New Reboot Cause. What's this?Just ran my ESP 27h without error. Just as I wrote about it, he rebooted, it took longer than usual.
There is something completely new. See the picture. An old and the new main screen summarized.
the left Side are old. The right Side are new.
ganz neu.jpg
ganz neu.jpg (87.94 KiB) Viewed 480 times
by schnurzel59
24 Mar 2019, 22:59
Forum: ESP Easy: Software
Topic: Reboot, Soft- or Hardware-Problem. My Solution
Replies: 2
Views: 318

Reboot, Soft- or Hardware-Problem. My Solution

27 hours without reboot.ESP-12E. Build: mega-ESP_Easy_mega_20190315_dev_ESP8266_4M.bin Lately I've had reboots more and more often. The reason was always the hardware watchdog. Sometimes after an hour. Then I tried a lot to get rid of the cause. Today he already runs 27 hours. It would be good to kn...
by schnurzel59
21 Mar 2019, 17:26
Forum: ESP Easy: Software
Topic: event without an event
Replies: 6
Views: 478

Re: event without an event

Hi, I thought the interval only refers to the transfer of data to the controller. (Home Matic). if I now set the interval to 0, the values are no longer transmitted automatically. But here is the second problem. It does not matter which Arduino IDE version or directory structure I use in the librari...
by schnurzel59
20 Mar 2019, 22:34
Forum: ESP Easy: Software
Topic: event without an event
Replies: 6
Views: 478

Re: event without an event

I use the mega-20190315
I can set all values, only not 0.
by schnurzel59
20 Mar 2019, 21:17
Forum: ESP Easy: Software
Topic: event without an event
Replies: 6
Views: 478

Re: event without an event

I can not set the interval to 0 It is automatically set to 60s.
by schnurzel59
20 Mar 2019, 13:16
Forum: ESP Easy: Software
Topic: event without an event
Replies: 6
Views: 478

event without an event

Hi, When will an event be triggered? A simple test: The following device is created. Device.jpg A Rule for the Test: on Testdev#Testvalue do event,RuleIsBeingExecuted endon Here the Log: 150758: EVENT: Testdev#Testvalue=0.00 150879: ACT : event RuleIsBeingExecuted 150892: Command: event 150893: EVEN...
by schnurzel59
15 Mar 2019, 14:25
Forum: ESP Easy: General Discussion
Topic: Problems with event call in rules ?
Replies: 5
Views: 541

Re: Problems with event call in rules ?

Hi Lenif, You say: Maybe there is a simple way to do it but it works on build mega-20181101. On the build from 20180305, when I use the button, my sonoff reboot. :( I think the not working version is these: 20190305. (Not 2018) ? Why do not you stay with version 20181101? If everything is going well...
by schnurzel59
12 Mar 2019, 15:24
Forum: ESP Easy: Software
Topic: NEXTION075 : WRITE = Timer,3
Replies: 3
Views: 355

Re: NEXTION075 : WRITE = Timer,3

Hi, I tested different things. Just as you can test the status of a gpio with an http query, so i wanted to see what happens when you query a timer. I had not expected to get a result. But the result had already confused me a bit. That was, however, 3 or 4 times repeatable, but never again. Is proba...
by schnurzel59
09 Mar 2019, 10:29
Forum: ESP Easy: Software
Topic: ESPEasy Test-Tool Excel DE EN
Replies: 3
Views: 527

Re: ESPEasy Test-Tool Excel DE EN

Hi,
Thank you.

A question. How can the attached pictures in the article be displayed as smaller thumbnails?
Thank you
by schnurzel59
09 Mar 2019, 01:11
Forum: ESP Easy: Software
Topic: Web Forms
Replies: 2
Views: 376

Re: Web Forms

what is my shoe size?
by schnurzel59
09 Mar 2019, 00:50
Forum: ESP Easy: General Discussion
Topic: [solved] Are any math functions usable in rules?
Replies: 6
Views: 660

Re: [solved] Are any math functions usable in rules?

Hi, The math functions are a bit confusing. The following examples speak for themselves. TaskValueSet,11,4,465-789 --- = -324 ok TaskValueSet,11,4,45/7-------- = 6,4286 ok TaskValueSet,11,4,3*98 -------- =294 ök TaskValueSet,11,4,2^57 -------- =144115188075855870 18 digits are stored without any pro...
by schnurzel59
09 Mar 2019, 00:19
Forum: ESP Easy: Software
Topic: NEXTION075 : WRITE = Timer,3
Replies: 3
Views: 355

NEXTION075 : WRITE = Timer,3

Hi,
I just tried to determine the status of a timer.
The answer to the command:
"http://192.168.1.226/control?cmd=status,Timer=3"
was "NEXTION075: WRITE = Timer, 3".What does that mean?

Best regards
Martin
by schnurzel59
09 Mar 2019, 00:07
Forum: ESP Easy: General Discussion
Topic: Controlling relays with nodemcu
Replies: 1
Views: 241

Re: Controlling relays with nodemcu

Hi, It's easier and safer to buy a simple charge controller. I just hope you know your way around with batteries. You can not use any relays. Heavy overcharging can cause very large damage to the battery. With deep discharge the battery is irretrievably broken. Depending on the size of the battery, ...
by schnurzel59
08 Mar 2019, 23:19
Forum: ESP Easy: Software
Topic: ESPEasy Test-Tool Excel DE EN
Replies: 3
Views: 527

ESPEasy Test-Tool Excel DE EN

Hallo Leute, Ich möchte hier mal ein einfaches Excel-VBA-Tool zum testen meiner ESP-MCU´s vorstellen. Also es betrifft ja eher die ESPEasy-Software. Es ist so möglich, im Hintergrund die Weboberfläche der ESPEasy zu haben, auch mit mehreren Fenstern und im Vordergrund mit Hilfe dieses Excel-Formular...
by schnurzel59
25 Feb 2019, 23:01
Forum: ESP Easy: Software
Topic: changed rules format?
Replies: 6
Views: 1305

Re: changed rules format?

hello grovkillen, I do not understand why some useless changes are made that I should not use then. These are only for testing, as you say. Who should test them if they only bring problems in existing configurations. I can not even change everything in my rules once a week just to test what you've c...
by schnurzel59
23 Feb 2019, 21:30
Forum: ESP Easy: Software
Topic: problem with chrome and rules and chrom cache?
Replies: 4
Views: 419

Re: problem with chrome and rules and chrom cache?

Hello,
I have the same problem under win 10 with firefox, chrome and edge.
is probably a common problem.
who knows the solution?
by schnurzel59
18 Feb 2019, 13:51
Forum: ESP Easy: Software
Topic: longpulse problem solved
Replies: 7
Views: 462

longpulse problem solved

Hello, sometimes logpulse works, another time not. I have finally got the prolem under control. it had nothing to do with the release for me. I have 8 relays connected. for a time longpulse worked without problems. now no Gpio switched back to the last state. Solution: I have not assigned a gpio out...