Search found 125 matches

by cherowley
06 Jun 2019, 15:54
Forum: ESP Easy: Hardware
Topic: HLW8032
Replies: 3
Views: 579

Re: HLW8032

I received one of these modules and despite best efforts cannot get it to read the correct voltage (reads 270 instead of 230), shame!
by cherowley
28 May 2019, 19:33
Forum: ESP Easy: Software
Topic: [SOLVED] out of memory
Replies: 6
Views: 595

Re: [SOLVED] out of memory

Just had my self build reset due to watchdog. This isn't good as it's not running any sensors, only plugin active is to drive my servos in my blinds so just inactive except for 10 seconds a day lol. Cant see it being a plugin if none are configured so guess it must be a problem with base framework e...
by cherowley
28 May 2019, 11:41
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Re: Core version

I have tried VS code a few times myself and it does have configuration option to define (in text configuration) how you want to define tasks. But since these are lost when I move to another computer (and not checked in, since they are quite personal), I am no longer using VS code myself. It is quit...
by cherowley
28 May 2019, 11:36
Forum: ESP Easy: Software
Topic: [SOLVED] out of memory
Replies: 6
Views: 595

Re: [SOLVED] out of memory

TD-er wrote:
28 May 2019, 10:55
What was the plugin that was really required?
Maybe I can add a remark to it to help others.
Hiya, not finished my hunting as yet but will let you know 😊
by cherowley
24 May 2019, 09:48
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Re: Core version

Thanks Waspie :)
by cherowley
22 May 2019, 13:16
Forum: ESP Easy: General Discussion
Topic: Platformio questions
Replies: 9
Views: 8912

Platformio questions

Hi! I'm trying to adjust to using platformio on vscode. When opening the src directory its complaining that c/c++ intellisense service does not support ino files. I can install the arduino extension to get rid of that message but then it complains that there's conflicts between it and the c/c++ exte...
by cherowley
21 May 2019, 16:58
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Re: Core version

I used the arduino IDE for the last couple years for ESPEasy but finally moved to POI a few months ago. It is considerably easier once its set up so rip the band-aid off and get it done Band-aid ripped! Ouch, still stinging lol! I wonder, is there a way to configure the vscode with platformio to ha...
by cherowley
20 May 2019, 09:58
Forum: ESP Easy: Software
Topic: [SOLVED] out of memory
Replies: 6
Views: 595

Re: out of memory

Yep did that just in case :) Anyways I've solved it sort of. I forgot I was running a macro on the source to remove unneeded plugins. It seems that at least one is required or the problems ensue! I've have to work through the 40+ plugins I remove to see which one causes the problem - a task which wi...
by cherowley
19 May 2019, 19:42
Forum: ESP Easy: Software
Topic: [SOLVED] out of memory
Replies: 6
Views: 595

[SOLVED] out of memory

hi! I've been developing a plugin and all ws going well but now espeasy keeps crashing. I got rid of plugin, recompiled but same problem. Re downloaded source and compiled uploaded same problem. Tried different chip same problem. Once I've entered the wifi details on 192.168.4.1 it reboots and i can...
by cherowley
18 May 2019, 23:46
Forum: ESP Easy: Software
Topic: Buttons in task settings
Replies: 6
Views: 446

Re: Buttons in task settings

Cool, used the html like you suggested as I wanted the clicking of +- to have immediate effect, cheers :)
by cherowley
18 May 2019, 14:47
Forum: ESP Easy: Software
Topic: Buttons in task settings
Replies: 6
Views: 446

Re: Buttons in task settings

Ah right, sorry vould you point me to a plugin which has plus minus buttons in the web page? Can't see one for looking lol!
by cherowley
18 May 2019, 14:12
Forum: ESP Easy: Software
Topic: Buttons in task settings
Replies: 6
Views: 446

Re: Buttons in task settings

Can this be done in the plugin without modifying the web server or other standard code?

My current plugin relied on my changes to the webserver.ino to add a few new webserver.on events you see and I want to rewrite for mega version and make it a standard plugin at the same time...
by cherowley
18 May 2019, 13:54
Forum: ESP Easy: Software
Topic: Buttons in task settings
Replies: 6
Views: 446

Buttons in task settings

Hi!

Is it possible to add buttons to the settings of a task plugin screen?

I'm doing a new plugin whereby it would be great to have some plus minus buttons on the plugin settings web screen to set plugin values...
by cherowley
17 May 2019, 23:42
Forum: ESP Easy: Hardware
Topic: HLW8032
Replies: 3
Views: 579

HLW8032

Hi!

Has anyone looked at the HLW032 chip?

Seem similar to the HLW8012 except output is serial (4800baud) and doesn't require calibration.

Electrodragon have a breakout board..
by cherowley
15 May 2019, 23:54
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Re: Core version

Ok so also failing to compile using platformio: Linking .pioenvs\normal_core_241_ESP8266_4M\firmware.elf .pioenvs\normal_core_241_ESP8266_4M\libFrameworkArduino.a(core_esp8266_main.cpp.o):(.text._ZL12loop_wrapperv+0x4): undefined reference to `setup' .pioenvs\normal_core_241_ESP8266_4M\libFrameworkA...
by cherowley
15 May 2019, 22:14
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Re: Core version

Thanks for the input chaps :) But doesn't pio rebuild it all every compile time so needlessly takes ages? Also hitting the build button proceeds to build tons of different versions, I guess that some files would need more edditing to stop that. and you can't just drop the required plugins in/out of ...
by cherowley
15 May 2019, 18:48
Forum: ESP Easy: General Discussion
Topic: Core version
Replies: 11
Views: 1340

Core version

Hi!

What core version should be used to compile the current mega versions?

Is it still possible to compile without using platformino just using the arduino ide or the vscode with arduino extension?


Thanks!
by cherowley
10 May 2019, 13:23
Forum: ESP Easy: General Discussion
Topic: Bad flash anything else except espeasy mega
Replies: 0
Views: 316

Bad flash anything else except espeasy mega

Hi! I've been using a wemos d1 mini for a few months for expirimenting. Originally it was flashed with firmware upto v147. All ok. Then more recently flashed with esp mega firmware. Again ok. However now I can't seem to flash it with anything else but mega firmware?! Any other firmwares (including t...
by cherowley
05 May 2019, 14:22
Forum: ESP Easy: Hardware
Topic: SOLVED :4 Servos
Replies: 4
Views: 465

SOLVED: Re: 4 Servos

Just a follow up in case anyone else wants to use more than 2 servos - by defining more instances it does actually work fine, I'm now using 4 servos with espeasy with no problems. The problem was the wiring. My servos power are connected together then linked to the psu with a single cable. This wire...
by cherowley
03 May 2019, 22:45
Forum: ESP Easy: Hardware
Topic: SOLVED :4 Servos
Replies: 4
Views: 465

Re: 4 Servos

Cheers Thomas, suspected it was a hardware limitation with hardware timers or the like..

Thanks for the pointer :)
by cherowley
03 May 2019, 21:52
Forum: ESP Easy: Hardware
Topic: SOLVED :4 Servos
Replies: 4
Views: 465

SOLVED :4 Servos

Hi! My project needs 4 servos (4 parts to the bay so 4 blinds). Anyway to achieve this on a single esp8266? I've tried altering code to have 4 servo objects but I presume they must use too many timers as it all get confused. (with teh 4 objects i tried using one at a time and all at once - sames res...
by cherowley
11 Nov 2018, 14:39
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

Oh for goodness sake, sorted now!

Appeared to be a combination of too fast upload speed (230k) bad psu and breadboard!
by cherowley
11 Nov 2018, 12:01
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

Doh!

Have set flashing params to 1meg/spiffs 128 dout and still won't boot after flashing my own compiled binary :(
Never had these probs in years..

This is on a h801, flashing a wemos d1 works and runs fine.
by cherowley
10 Nov 2018, 14:36
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

Oh yes totally understand, it's just me preferring vs as that's what I use in my day job. I also like the way visual studio only recompiles changes so greatly speeds up the test/change/rebuild cycle.. I've been using espeasy for a few years now, contributed a basic ir tx module and rgbw controller p...
by cherowley
10 Nov 2018, 14:16
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

They are actually initialized through the PlatformIO.ini file OK thanks I'll take a look in there.. I'm using arduino ide BTW, not a fan of platform for my sins hehe. Would prefer to use visual studio with visual micro again but haven't been able to get it compiled anymore using the mega 2.x versio...
by cherowley
10 Nov 2018, 12:24
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

grovkillen wrote:
10 Nov 2018, 11:40
Look at the source please.
Ah didn't know they could be set in source, I've always done it from the menu in the ide..
by cherowley
10 Nov 2018, 10:26
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

What parameters are the prebuilt 1meg versions done with?

Mode?
Spiff size?

Thanks!
by cherowley
09 Nov 2018, 22:08
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

Re: 1meg flashing problems

Hiya, hmm yeah tried it with a few different bits of flashing software, all of which flash the prebuilt 1meg image ok..
by cherowley
09 Nov 2018, 19:01
Forum: ESP Easy: General Discussion
Topic: 1meg flashing problems
Replies: 11
Views: 1148

1meg flashing problems

Hi! I'm trying to flash a H801 rgbw unit with a customer compiled firmware (need plugins from the playground).. I've amend the used plugins and controllers and the size is 644k. Flashes ok but image doesn't run 17:51:04.888 -> ets Jan 8 2013,rst cause:2, boot mode:(3,7) 17:51:04.888 -> 17:51:04.888 ...
by cherowley
20 Jul 2017, 12:42
Forum: ESP Easy: General Discussion
Topic: Saving variable value in Flash Memory
Replies: 7
Views: 3246

Re: Saving variable value in Flash Memory

In my thermostat/timer plugin I write the set point & times to flash: case PLUGIN_WEBFORM_SAVE: { //example to save the temp set point tmpStr = WebServer.arg("plugin_121_SetTemp"); Settings.TaskDevicePluginConfigFloat[event->TaskIndex][0] = tmpStr.toFloat (); SaveTaskSettings(event->TaskIndex); succ...
by cherowley
20 Jul 2017, 12:25
Forum: RFLink: Unsupported devices
Topic: 3 button smart home wall panel
Replies: 10
Views: 3021

Re: 3 button smart home wall panel

Hi!

Any developments on this? :)
by cherowley
26 Jan 2017, 14:41
Forum: RFlink: General Discussions
Topic: Lightwave mood switch error
Replies: 8
Views: 2347

Re: Lightwave mood switch error

Many thanks William for implementing this :) :D
by cherowley
26 Jan 2017, 14:14
Forum: ESP Easy: Hardware
Topic: H801 : RGB controller based on ESP8266 avalaible from China
Replies: 120
Views: 69628

Re: H801 : RGB controller based on ESP8266 avalaible from China

I've created a basic plugin (29) for Milight emulation. Only responds to group 1. New item in devices - Milight RGBW. Set pins used and udp port for milight emulation. Only does basic colour/brightness plus a couple new other http commands. To use drop the plugin into the source directory and compi...
by cherowley
24 Jan 2017, 12:37
Forum: RFlink: General Discussions
Topic: Lightwave mood switch error
Replies: 8
Views: 2347

Re: Lightwave mood switch error

Nor me lol!

I assume domoticz would need to be coded to link it to switches?

How about instead you change rflink to send switch commands instead of "mood" commands? That would be much quicker to be implemented than waiting for domoticz update :D
by cherowley
24 Jan 2017, 12:08
Forum: RFlink: General Discussions
Topic: Lightwave mood switch error
Replies: 8
Views: 2347

Re: Lightwave mood switch error

Is it something that has to be compiled/added to Domoticz?
by cherowley
22 Jan 2017, 18:22
Forum: RFlink: General Discussions
Topic: Lightwave mood switch error
Replies: 8
Views: 2347

Lightwave mood switch error

hi! I'm trying to use the lightwave mood switch with latext domoticz beta but when pressing any of the mood buttons I get an error in the domoticz log: E.G Error: RFLink: Unhandled switch command: MOOD=01 Error: RFLink: Unhandled switch command: MOOD=02 Error: RFLink: Unhandled switch command: MOOD=...
by cherowley
29 Nov 2016, 13:57
Forum: ESP Easy: Software
Topic: ESP Easy next stable... (release candidates)
Replies: 155
Views: 47009

Re: ESP Easy next stable... (release candidates)

Hi Martinus, I've had these problems for a while, dating back to 120 I think but not 100%... Happens with http and mqtt. Forgot to say, even though when it happens I can't ping and can't access the web page, issuing http commands to the esp still works (no confirmation response though). - Stable web...
by cherowley
25 Nov 2016, 10:15
Forum: ESP Easy: Software
Topic: Mqtt gpio control from domoticz
Replies: 3
Views: 1523

Re: Mqtt gpio control from domoticz

Ah many thanks :)

I thought I'd downloaded the libs and the pubsub was "patched" already as mentioned in other posts - that's what I get for assuming!

Cheers :)
by cherowley
24 Nov 2016, 18:00
Forum: ESP Easy: Software
Topic: Mqtt gpio control from domoticz
Replies: 3
Views: 1523

Mqtt gpio control from domoticz

Hi!

Ok, I've tried but I can't seem to get this working.

I've used the mqtt helper but no joy.

Anyone got a few step by step idiot instructions perchance? :)
by cherowley
22 Nov 2016, 16:20
Forum: ESP Easy: Software
Topic: ESP Easy next stable... (release candidates)
Replies: 155
Views: 47009

Re: ESP Easy next stable... (release candidates)

Hello, Seems, this is a bug report for release 140. If I am posting to wrong topic, please, point me to correct one. The ESP module with release 140 runs MQTT publishing of HTU21, BMP180, and light sensors. It works fine (missing some reports, not a concern here). After 2-3 hours of work it is impo...
by cherowley
11 Nov 2016, 14:20
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

Hi bob,

I had to do a search in the bin file:

search for: 04FEFDFFF0F0F0E0E0E0E10AFFFFF8

Change byte under second F8 from 1 to 0

repeat for second match


Hmm, i scribbled this note when I was doing it but now reading it back it's a bit cryptic sorry!
by cherowley
10 Nov 2016, 23:15
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

Thanks supergeek, very good to know :)
by cherowley
27 Oct 2016, 17:41
Forum: ESP Easy: Software
Topic: Devices disappearing from node list
Replies: 0
Views: 525

Devices disappearing from node list

Ah noo! Just as I was about to use the the nodelist age to detect offline remote nodes, I've watched all my sensors lose contact with each other over the last 10 minutes?! To start with the 8 devices all showed all the other nodes, then they started dropping off until now all devices show only their...
by cherowley
27 Oct 2016, 09:42
Forum: ESP Easy: Software
Topic: ESP Easy next stable... (release candidates)
Replies: 155
Views: 47009

Re: ESP Easy next stable... (release candidates)

Current bugstatus: Bug #01 FIXED in R138 : Clock event at system boot issues quote] I'm not sure if it's related to the above but I'm still getting the problem whereby sometimes the clock is NOT set after boot in version 140. Can't detect a pattern - seems random. Sometimes enabling/disabling the u...
by cherowley
26 Oct 2016, 17:15
Forum: ESP Easy: Software
Topic: ESP Easy next stable... (release candidates)
Replies: 155
Views: 47009

Re: ESP Easy next stable... (release candidates)

[quote="Martinus"]Current bugstatus: Bug #01 FIXED in R138 : Clock event at system boot issues quote] I'm not sure if it's related to the above but I'm still getting the problem whereby sometimes the clock is NOT set after boot in version 140. Can't detect a pattern - seems random. Sometimes enablin...
by cherowley
25 Oct 2016, 15:52
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

No probs, give me a shout if you get stuck :)

Yeah, would be nice to have an option somewhere to define the xtal freq like we can for flash speed, flash size, spiffs etc
by cherowley
25 Oct 2016, 11:41
Forum: RFLink: Unsupported devices
Topic: Lightwaverf mood switch
Replies: 11
Views: 3457

Re: Lightwaverf mood switch

Hello again!

Just checking is it you guys @ stunteam or the guys @ domoticz needed to get this done?

Should I contact someone over there?

Cheers!
by cherowley
25 Oct 2016, 10:03
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

Hi Bob, Just to let you know I've successfully flashed the plugs and have them working now. It is indeed the problem of them having 40mhz xtals - if you look at the board you can see it marked 40 too.. http://www.esp8266.com/viewtopic.php?f=13&t=12175 I had to edit the bin file setting a couple of b...
by cherowley
24 Oct 2016, 09:41
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

Hiya, Hmm, in my case that ties up perfectly as when i boot the plug i get a read out at 115200 - which does then suggest a 40mhz xtal as indicated in your post :) I posted over there about this and someone gave some ideas on making sure the xtal speed is set correctly: http://www.esp8266.com/viewto...
by cherowley
21 Oct 2016, 21:09
Forum: ESP Easy: Hardware
Topic: UK power socket with HF-W02 module
Replies: 13
Views: 3590

Re: UK power socket with HF-W02 module

Funnily enough just last week I discovered the very same about a couple of plugs I've had for months. Having same probs with flashing though. Flashes on but won't run.. It will run the demo arduino sketches though but the baud rate is different from what is set in code. The WiFi stuff also doesn't w...