Somfy Exavia 500 pair with rflink

About receivers, transmitters, transceivers, connections, antennas etc.

Moderators: rtenklooster, BertB, Voyager, Stuntteam

Post Reply
Message
Author
racoonx2p
Normal user
Posts: 1
Joined: 27 Oct 2019, 18:32

Somfy Exavia 500 pair with rflink

#1 Post by racoonx2p » 27 Oct 2019, 18:47

Hello,

I'm using Robotdyn ATmega2560+ESP8266 and RFlink for Somfy devices. I've set it up for my two blinds and it's working as expected. Now I bought Somfy Exavia 500 (Automatic gate opening) but I'm unable to find out how to do pairing with this motor. There are two keypop 2 controlers attached. Pairing is done as on the picture bellow:
chrome_AFMqQtAr7F.png
chrome_AFMqQtAr7F.png (46.14 KiB) Viewed 738 times
Manual for Exavia

I can see output in log when I press buttons on remote controllers in RFLinkLoader:

Code: Select all

20;11;Debug;RTS P3;a4f50043bbb549cc0033;
20;12;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;13;Debug;RTS P1;a4f20044bbb549c40019;
20;14;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;15;Debug;RTS P2;a4f20044bbb549c80026;
20;16;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;17;Debug;RTS P3;a4f20044bbb549cc0033;
20;18;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;19;Debug;RTS P1;a4f00046bbb549c40019;
20;1A;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;1B;Debug;RTS P2;a4f00046bbb549c80026;
20;1C;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;1D;Debug;RTS P3;a4f00046bbb549cc0033;
20;1E;RTS;ID=2bbb549;SWITCH=01;CMD=STOP;
20;1F;Debug;RTS P1;a4f50143bab549c40019;
20;20;RTS;ID=2bab549;SWITCH=01;CMD=STOP;
When I tried to pair it the same way as blinds I got OK answer:

Code: Select all

10;RTS;555555;0417;9;PAIR;
20;C6;OK;
But when I send command from RFLinkLoder nothing happens. I think problem is that I'm unable to set motor to programming mode and pair RFlink with it.

Any help will/would be appreciated.

Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests