RFLink with NodeMCU, readings are not sent on wifi

About receivers, transmitters, transceivers, connections, antennas etc.

Moderators: rtenklooster, Voyager, BertB, Stuntteam

Message
Author
seb82
Normal user
Posts: 57
Joined: 05 Sep 2018, 10:56

Re: RFLink with NodeMCU, readings are not sent on wifi

#51 Post by seb82 » 18 Apr 2021, 13:29

konehead wrote: 13 Apr 2021, 21:36 The DEV branch is really good. You should promote it to a formal release. I am not a developer, but can I help you with the latest things to be done? I believe that you did a very good job, let's finish the last mile together. I can write a help file and do some testing - in case if it supports you. I also believe RFLINK should mention this solution on their website (in case you are ok with this). I do like this solution, because there is no serial connection required between my RPI en the RFlink
I have updated the readme file and brought some minor changes to the interface. At the moment, even though I have tested it with an esp01 and RFLink, the device I use in a production environment is remote and I cannot update and test before a few months. If it would possible to test the last dev branch version, then I could update the master branch and publish release 1.0.
Sébastien - espRFLinkMQTT gateway RFLink MQTT on esp

seb82
Normal user
Posts: 57
Joined: 05 Sep 2018, 10:56

Re: RFLink with NodeMCU, readings are not sent on wifi

#52 Post by seb82 » 18 Apr 2021, 13:30

mrshark wrote: 25 May 2020, 10:52 anyone knows which is the pin to be set on this board for the "mega reset"? thanks
In the dev branch and future release 1, this can be chosen in config.h if compiling your own firmware or in any case from the web interface.
Sébastien - espRFLinkMQTT gateway RFLink MQTT on esp

seb82
Normal user
Posts: 57
Joined: 05 Sep 2018, 10:56

Re: RFLink with NodeMCU, readings are not sent on wifi

#53 Post by seb82 » 02 May 2021, 01:21

For information, release v1.0 has just been published and includes all latest improvements from dev branch.
Sébastien - espRFLinkMQTT gateway RFLink MQTT on esp

konehead
Normal user
Posts: 10
Joined: 10 Apr 2021, 13:04

Re: RFLink with NodeMCU, readings are not sent on wifi

#54 Post by konehead » 10 May 2021, 16:02

seb82 wrote: 02 May 2021, 01:21 For information, release v1.0 has just been published and includes all latest improvements from dev branch.

Many thanks for the v1.0 version!
sorry for the late response. I had some projects to finish @ work. Today I have tested V1, and did a rol back. When i install V1 i get the ping/pong issue back (bridge reboots every x seconds) and the Web GUI is very instable. The software acts as the version before the last development version. As you might know, i used the development version, this version is very stable. What kind of information do you need from me to fix this? I haven't used the bin file, i took all the Arduino files and uploaded it to my ESP..

seb82
Normal user
Posts: 57
Joined: 05 Sep 2018, 10:56

Re: RFLink with NodeMCU, readings are not sent on wifi

#55 Post by seb82 » 10 May 2021, 16:29

konehead wrote: 10 May 2021, 16:02 Many thanks for the v1.0 version!
sorry for the late response. I had some projects to finish @ work. Today I have tested V1, and did a rol back. When i install V1 i get the ping/pong issue back (bridge reboots every x seconds) and the Web GUI is very instable. The software acts as the version before the last development version. As you might know, i used the development version, this version is very stable. What kind of information do you need from me to fix this? I haven't used the bin file, i took all the Arduino files and uploaded it to my ESP..
This is weird as release 1.0 is almost exactly the same as the dev version one year ago.

What kind of hardware do you use for the esp?

Which was the last dev version that was working? Which date?
Sébastien - espRFLinkMQTT gateway RFLink MQTT on esp

konehead
Normal user
Posts: 10
Joined: 10 Apr 2021, 13:04

Re: RFLink with NodeMCU, readings are not sent on wifi

#56 Post by konehead » 10 May 2021, 20:25

seb82 wrote: 10 May 2021, 16:29
konehead wrote: 10 May 2021, 16:02 Many thanks for the v1.0 version!
sorry for the late response. I had some projects to finish @ work. Today I have tested V1, and did a rol back. When i install V1 i get the ping/pong issue back (bridge reboots every x seconds) and the Web GUI is very instable. The software acts as the version before the last development version. As you might know, i used the development version, this version is very stable. What kind of information do you need from me to fix this? I haven't used the bin file, i took all the Arduino files and uploaded it to my ESP..
This is weird as release 1.0 is almost exactly the same as the dev version one year ago.

What kind of hardware do you use for the esp?

Which was the last dev version that was working? Which date?
I was surprised too! I used the dev version from your post on 30 Apr 2020, 12:24 (used the link + bin file instruction). Since there is no version controll of the dev version, i don't know the exact version. Ofcourse I have a copy on my laptop. I clicked the link in your post of 30 Apr 2020, 12:24 and i saw the dev branch is updated as well (which is logic)

The hardware: I use the Arduino Mega + NodeMCU (from nodo-shop.nl). I can send you by e-mail my copy of the dev versions..

seb82
Normal user
Posts: 57
Joined: 05 Sep 2018, 10:56

Re: RFLink with NodeMCU, readings are not sent on wifi

#57 Post by seb82 » 11 May 2021, 00:18

konehead wrote: 10 May 2021, 20:25 The hardware: I use the Arduino Mega + NodeMCU (from nodo-shop.nl). I can send you by e-mail my copy of the dev versions..
If you use the RFLink Wifi board from Nodo shop, in config.h you should uncomment #define RFLINK_WIFI_BOARD. Indeed, this board uses a watchdog that must be triggered regularly, otherwise it resets the esp.

This is now commented as it is very specific to this board and not required for most users.
Sébastien - espRFLinkMQTT gateway RFLink MQTT on esp

konehead
Normal user
Posts: 10
Joined: 10 Apr 2021, 13:04

Re: RFLink with NodeMCU, readings are not sent on wifi

#58 Post by konehead » 11 May 2021, 21:35

seb82 wrote: 11 May 2021, 00:18
konehead wrote: 10 May 2021, 20:25 The hardware: I use the Arduino Mega + NodeMCU (from nodo-shop.nl). I can send you by e-mail my copy of the dev versions..
If you use the RFLink Wifi board from Nodo shop, in config.h you should uncomment #define RFLINK_WIFI_BOARD. Indeed, this board uses a watchdog that must be triggered regularly, otherwise it resets the esp.

This is now commented as it is very specific to this board and not required for most users.
This was the issue! Thanks for this notification. I missed the uncomment action :). Works really well

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests