RFLink mini GPIO problem.

About receivers, transmitters, transceivers, connections, antennas etc.

Moderators: rtenklooster, Voyager, BertB, Stuntteam

Post Reply
Message
Author
costo
Normal user
Posts: 490
Joined: 21 Nov 2015, 15:03

RFLink mini GPIO problem.

#1 Post by costo » 08 Apr 2017, 18:44

Today I flashed RFLink R46 into my mega2560 which is connected to a RasberryPi with Domoticz. Until now I used R39 which did well for me.
When reading the faq of R46 release I was triggered by this part http://www.nemcon.nl/blog2/faq#GPIO

I have a special use for these 4 INPUT pins together with a receiver decoder on 315MHz, like this one: http://www.ebay.nl/itm/122154594503?_tr ... EBIDX%3AIT. This receiver-decoder has 4 Data outputs and a output called ´Data Valid´.
I happen to have a few 4 button 315MHz remotes and think this can perfectly be integrated with RFLink/Domoticz using the new R46 GPIO feature.

But ........
Something seems to be wrong, I cannot trigger pin 26,27,28 or 29 by making it high or low.
RFLink does not generate a message like this:
20;1A;GPIOset;ID=0;SWITCH=0;CMD=ON;
20;1B;GPIOset;ID=0;SWITCH=0;CMD=OFF;
I do not see it nor in the ArduinoIDE_monitor, nor in Domoticz.
I checked allow new hardware/Devices in the Domoticz setup.
But no response, what can be wrong ?

Related question is:
I tried from within the IDE-monitor the command: 1O;GPIOset;30;0;ON & OFF and that actually works, I can turn on/off a led.
But .... how can I generate a command like this from within Domoticz to trigger one of the OutputPins D30......D39
Last edited by costo on 08 Apr 2017, 22:21, edited 2 times in total.

User avatar
Stuntteam
Site Beheer
Posts: 648
Joined: 27 Jan 2016, 16:46

Re: RFLink mini GPIO problem.

#2 Post by Stuntteam » 08 Apr 2017, 21:21

Did you enable the minigpio?

what does command
10;status;
tell you?
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

costo
Normal user
Posts: 490
Joined: 21 Nov 2015, 15:03

Re: RFLink mini GPIO problem.

#3 Post by costo » 08 Apr 2017, 21:39

20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;

setGPIO=OFF that must be the reason


think ..... think ...... for a few ninutes.

solved: Command 10;setGPIO=ON;

It is working now

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest