pulscouter on esp 32

Moderators: rtenklooster, Voyager, BertB, Stuntteam

Forum rules
You have entered the experimental forum, beware!!!
Post Reply
Message
Author
har
Normal user
Posts: 12
Joined: 23 Nov 2015, 14:49

pulscouter on esp 32

#1 Post by har » 03 May 2021, 20:59

Hi,
I have used 8266 units in combination with a pulscouter to measure power consumption. This has always worked with help of a risistor.
Now I am trying to do the same with a esp32 dev unit, one with external antenne, to get beter reach over a distance.
I used gipo 33-34-35. I get pulses but far to much, even when no power is used.
When I use a extrenal aide as the tcr5000 it works.
Anyone an idea what this might be?

Thanks,
Har

TD-er
Core team member
Posts: 4672
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: pulscouter on esp 32

#2 Post by TD-er » 03 May 2021, 21:19

Perhaps you had used pins on the ESP8266 that were pulled up by some pull-up resistors and not using those on the ESP32?

Things that cause false triggers:
- Long wires
- High impedence input on the ESP side.

What happens with high impedance input is that you need only a very low current to change the state.
Low current is easily generated through noise over some cables.

So what you should do is use some pull-up resistor to "pull" the signal to a steady (high) state and when you pull the level down by your sensing device, it should draw some current which is not easy to generate by noise. Something like a few mA is often enough to overcome the noise.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests