First LED of Neopixel ring always ON [SOLVED]

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

First LED of Neopixel ring always ON [SOLVED]

#1 Post by pppp33 » 11 Oct 2018, 21:35

Hi there, me too with NeoPixel !
I didn't resist and bout the entire 241-led disk (see photo)
The attachment photo1.jpg is no longer available
I connected them in the correct order and got basic Neopixel work.
Now, the strange thing.
After i send the "on" command to first LED with (as an example):

http://192.168.1.163/control?cmd=neopixel,1,0,0,100

I can't switch it off anymore it, whatever command I send.
It looks like the green led is always ON.
Has somebody got same problem ?
I already tried to change the ring, and got same behaviour.
Thx for help.....
Paolo
Attachments
photo1.jpg
photo1.jpg (1.89 MiB) Viewed 1361 times
Last edited by pppp33 on 12 Oct 2018, 21:55, edited 1 time in total.

TD-er
Core team member
Posts: 1619
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: First LED of Neopixel ring always ON

#2 Post by TD-er » 12 Oct 2018, 01:39

Have you set the correct Strip Type? (RGB / RGBW)
And can you set a 5th parameter to 0 in the command?

Code: Select all

            // (1) NeoPixel,<led nr>,<red 0-255>,<green 0-255>,<blue 0-255>
            Plugin_038_pixels->setPixelColor(event->Par1 - 1, Plugin_038_pixels->Color(event->Par2, event->Par3, event->Par4, event->Par5));
As you can see, there is a 5th parameter used to set the color and maybe that one slips through to the next LED.

pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

Re: First LED of Neopixel ring always ON

#3 Post by pppp33 » 12 Oct 2018, 14:40

Hello TDer,
I did some more testing, and:
- no visible difference between RGB and RGBW
- led 1 is locked to 100% green
- if I power off the disc, led 1 stays off until first command
- If I issue something like:
http://192.168.1.163/control?cmd=neopixel,1,0,0,0,0,0,0
with some more zeroes, :)
I get no error, but can't switch off led 1
Thanx in advance for yr help.....
Paolo

pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

Re: First LED of Neopixel ring always ON

#4 Post by pppp33 » 12 Oct 2018, 21:39

Solved !
I used the same pin for wifi status led and Neopixel output !
Thanx TDer for support !
Regards....
Paolo
p.s. I'm also checking neopixel clock (plugin070) and it's running fine for now....
Attachments
neoclock.jpg
neoclock.jpg (1.68 MiB) Viewed 1315 times

TD-er
Core team member
Posts: 1619
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: First LED of Neopixel ring always ON [SOLVED]

#5 Post by TD-er » 13 Oct 2018, 15:46

Great to see it now works.

And just out of curiosity, do you have a link (or links) to these rings?
Is it one set or did you just combine all available ring radius boards?

jjansen
Normal user
Posts: 20
Joined: 17 Oct 2016, 14:20

Re: First LED of Neopixel ring always ON [SOLVED]

#6 Post by jjansen » 13 Oct 2018, 17:51


TD-er
Core team member
Posts: 1619
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: First LED of Neopixel ring always ON [SOLVED]

#7 Post by TD-er » 13 Oct 2018, 21:51

jjansen wrote:
13 Oct 2018, 17:51
https://www.aliexpress.com/item/Address ... 69128.html
The 241 LED version
Thanks

pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

Re: First LED of Neopixel ring always ON [SOLVED]

#8 Post by pppp33 » 14 Oct 2018, 10:33

Yes, that's it ! I chose black background.

Just an addition:
i combined BASIC Neopixel AND Neopixel CLOCK plugins, so I can lit up a static pattern (starting at led 61, for example the center LED) AND HMS leds on the outer ring.....
Next step could be fun to have faces/emoji on the disk.... :D
But we need an emoji "painter" and a "block transfer" plugin....
Regards
Paolo

User avatar
grovkillen
Core team member
Posts: 3263
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: First LED of Neopixel ring always ON [SOLVED]

#9 Post by grovkillen » 14 Oct 2018, 11:22

pppp33 wrote:
14 Oct 2018, 10:33
Yes, that's it ! I chose black background.

Just an addition:
i combined BASIC Neopixel AND Neopixel CLOCK plugins, so I can lit up a static pattern (starting at led 61, for example the center LED) AND HMS leds on the outer ring.....
Next step could be fun to have faces/emoji on the disk.... :D
But we need an emoji "painter" and a "block transfer" plugin....
Regards
Paolo
Pictures or it's just talk ;)

Sounds really interesting!
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

Re: First LED of Neopixel ring always ON [SOLVED]

#10 Post by pppp33 » 14 Oct 2018, 12:18

This is a (ugly) picture of the idea: happy, sad, etc.....
I made it with a (long) sequence of commands like this:

curl http://192.168.1.163/control?cmd=neopixel,124,100,100,0
....
....


but we need something more "human" :)

regards
Paolo
Attachments
happy_clock_2.jpg
happy_clock_2.jpg (952.83 KiB) Viewed 1256 times

User avatar
grovkillen
Core team member
Posts: 3263
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: First LED of Neopixel ring always ON [SOLVED]

#11 Post by grovkillen » 14 Oct 2018, 13:36

Hehe, looks good :)
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

pppp33
Normal user
Posts: 67
Joined: 25 Oct 2015, 17:53

Re: First LED of Neopixel ring always ON [SOLVED]

#12 Post by pppp33 » 14 Oct 2018, 16:35

....and this is the "sad" one....
Attachments
sad_clock.jpg
sad_clock.jpg (1.64 MiB) Viewed 1250 times

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests