ESP easy reboot

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Clown
Normal user
Posts: 4
Joined: 14 Nov 2015, 17:35

ESP easy reboot

#1 Post by Clown » 16 Nov 2015, 17:16

Hi,

I've got this board: http://www.aliexpress.com/item/V3-Wirel ... 84139.html

But it's not stable with ESPEasy,
Currently installed build #39, try'd older builds, same issue.
Arduino software -> Tools -> Board: NodeMCU 1.0 ESP12E

The board is stable with different code.
What can be the problem?

ambassadoro
Normal user
Posts: 40
Joined: 17 Nov 2015, 15:58

Re: ESP easy reboot

#2 Post by ambassadoro » 18 Nov 2015, 14:54

Try to stabilize the power. That often helps alot. A bigger capacitor between + and ground can help to bring enough power when needed.

Clown
Normal user
Posts: 4
Joined: 14 Nov 2015, 17:35

Re: ESP easy reboot

#3 Post by Clown » 09 Dec 2015, 10:15

Updated ESP core to 2.0.0, re-uploaded the current build #48 The restart problem is gone! Seems to have much more free memory space now..

Image

Miki
Normal user
Posts: 9
Joined: 21 Dec 2015, 13:22

Re: ESP easy reboot

#4 Post by Miki » 28 Dec 2015, 20:17

Same Problem here.

The nodemcu Board restarts every 30min.

ESP core 2.0.0 build #48

It is stable for ~30min. Then the webinterface is not rechable and in the Serial Monitor this appears:

Code: Select all

HTTP : connection failed
WD   : Uptime 31 ConnectFailures 30 FreeMem 26624
WD   : Uptime 32 ConnectFailures 30 FreeMem 27136
ADC  : Analog value: 1024
HTTP : connection failed
Delayed Reset 60
Delayed Reset 59
Delayed Reset 58
Delayed Reset 57
Delayed Reset 56
Delayed Reset ..
..
Delayed Reset 1

 ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x4010f000, len 1264, room 16 
tail 0
chksum 0x42
csum 0x42
~ld
ªU
INIT : Booting Build nr:48
WIFI : Connecting...
INIT : I2C
INIT : Boot OK
INIT : Normal boot
WD   : Uptime 0 ConnectFailures 0 FreeMem 28008
ADC  : Analog value: 1024

Martinus

Re: ESP easy reboot

#5 Post by Martinus » 28 Dec 2015, 20:31

Miki wrote:Same Problem here.

The nodemcu Board restarts every 30min.

ESP core 2.0.0 build #48

It is stable for ~30min. Then the webinterface is not rechable and in the Serial Monitor this appears:

WD : Uptime 32 ConnectFailures 30 FreeMem 27136
WD : Uptime 32 ConnectFailures 30 FreeMem 27136

This is a different issue and it is by design. If the ESP can't make a connection to the controller, it will reboot after 30 consecutive failures.

You should really solve this issue first:

HTTP : connection failed

Miki
Normal user
Posts: 9
Joined: 21 Dec 2015, 13:22

Re: ESP easy reboot

#6 Post by Miki » 28 Dec 2015, 20:43

Thank You Martinus.

If i don´t use a Controller (in my Lab Environment), can i deactivated it in the espeasy config?

Code: Select all

#define DEFAULT_PROTOCOL    1                   // Protocol used for controller communications
0 for no Controller?

costo
Normal user
Posts: 490
Joined: 21 Nov 2015, 15:03

Re: ESP easy reboot

#7 Post by costo » 28 Dec 2015, 21:56

Miki wrote:Thank You Martinus.

If i don´t use a Controller (in my Lab Environment), can i deactivated it in the espeasy config?

Code: Select all

#define DEFAULT_PROTOCOL    1                   // Protocol used for controller communications
0 for no Controller?
In GUI under devices are the sensor tabs you will find a box named ' Send Data ' which is ticked on by default. If you deactivate this box for all your active sensors ESPEasy will stop trying to connect to a controller. So there will be no more ConnectFailures and so there will be no reboot after 30 minutes.

DMeekelenkamp
Normal user
Posts: 35
Joined: 11 Nov 2015, 13:52

Re: ESP easy reboot

#8 Post by DMeekelenkamp » 29 Dec 2015, 10:00

I had the same issue. Unfortunately no body responded to my latest post http://www.esp8266.nu/forum/viewtopic.p ... 3&start=10

But that should be the solution. I also didn't know that the esp had to connect to a controller. But I missed the tick box send data...
Last edited by DMeekelenkamp on 29 Dec 2015, 10:02, edited 1 time in total.

costo
Normal user
Posts: 490
Joined: 21 Nov 2015, 15:03

Re: ESP easy reboot

#9 Post by costo » 29 Dec 2015, 14:59

I think it is possible to change line 490 in the WebServer module:
Settings.TaskDeviceSendData[index - 1] = true;
to
Settings.TaskDeviceSendData[index - 1] = false;

This will result in a default not checked value of the 'Data Send' box and will prevent the ConnectFailures and reboot when this reaches count 30.

@ Martinus,
Maybe the defaultvalue should better be false instead of true ?
If you want to send data to a controller it is more logical to check this box and if you are only testing with ESPEasy you do not think about it.

Dylantje
Normal user
Posts: 255
Joined: 11 Oct 2015, 16:51

Re: ESP easy reboot

#10 Post by Dylantje » 30 Dec 2015, 10:38

I have the same problem with this board .
I still have version on stand 015 and thought that was it.

Is this THE solution to get it stable?

Is there now come a new version of espeasy ?
Or do i have to change the settings in the sketch?

User avatar
ManS-H
Normal user
Posts: 234
Joined: 27 Dec 2015, 11:26
Location: the Netherlands

Re: ESP easy reboot

#11 Post by ManS-H » 02 Jan 2016, 21:52

Martinus wrote:
Miki wrote:Same Problem here.

You should really solve this issue first:

HTTP : connection failed
Martinus, give me a hint where i must looking, have the same problem here.

rtenklooster
Normal user
Posts: 320
Joined: 15 Apr 2015, 14:17

Re: ESP easy reboot

#12 Post by rtenklooster » 03 Jan 2016, 00:19

costo wrote: @ Martinus,
Maybe the defaultvalue should better be false instead of true ?
If you want to send data to a controller it is more logical to check this box and if you are only testing with ESPEasy you do not think about it.
I don't agree... i think 90% of the users is using esp combined with a controller. This is a wild guess but opt-in would cause a lot of questions about not updating values in controllers.
Richard - Groningen (NL) - Image

costo
Normal user
Posts: 490
Joined: 21 Nov 2015, 15:03

Re: ESP easy reboot

#13 Post by costo » 03 Jan 2016, 00:41

For both options there will be some who agree or disagree.

I myself think it would be a nice option if in the Config page there would be an optional box for 'Send Data to server' that would be on by defailt and it would be obvious to make it inactive if you do not fill in 'Controller IP' because you do not use a controller at the moment. A logical place for this box could be just above Protocol.
When it is on, by default, every new added device would have the 'Send data' box active and could be set inactive for every device just like it is right now.

edit:
It will be easy to advice people who have reset problems after 30 minutes to make this box inactive. They may have problems connecting to a server which they do not know about.

User avatar
ManS-H
Normal user
Posts: 234
Joined: 27 Dec 2015, 11:26
Location: the Netherlands

Re: ESP easy reboot

#14 Post by ManS-H » 03 Jan 2016, 11:34

rtenklooster wrote:
costo wrote: @ Martinus,
Maybe the defaultvalue should better be false instead of true ?
If you want to send data to a controller it is more logical to check this box and if you are only testing with ESPEasy you do not think about it.
I don't agree... i think 90% of the users is using esp combined with a controller. This is a wild guess but opt-in would cause a lot of questions about not updating values in controllers.
If i talk for myself, in this stage i'm only work with the ESP-01 and a DHT11. The ESP8266 is new for me so i will concentrate me only on this item to see how it work. If all is stable and i understand it i will connect it on a controller

Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests