Nodemcu Bme280

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
helio58
Normal user
Posts: 20
Joined: 11 Mar 2017, 10:21

Nodemcu Bme280

#1 Post by helio58 » 18 Apr 2017, 19:19

Hi,
I m using a Nodemcu with Bme280 esp easy mega v2.0.0-dev7.
Have connect Bme280 sda to D3 and scl to D4 .
I got wrong temperature difference +6 degrees celsius .
I read if using D3 and D4 no need of resistors.
Any suggestions ?

User avatar
grovkillen
Core team member
Posts: 3302
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Nodemcu Bme280

#2 Post by grovkillen » 18 Apr 2017, 19:33

BME280 might be faulty? Try to calibrate it to find out or simply use %value%-6 as formula.
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

helio58
Normal user
Posts: 20
Joined: 11 Mar 2017, 10:21

Re: Nodemcu Bme280

#3 Post by helio58 » 18 Apr 2017, 19:55

grovkillen wrote:
18 Apr 2017, 19:33
BME280 might be faulty? Try to calibrate it to find out or simply use %value%-6 as formula.
Thanks grovkillen.
I m using the formula %value%-6.
I thought I was doing something wrong .
Thanks

BertB
Normal user
Posts: 1020
Joined: 25 Apr 2015, 14:39

Re: Nodemcu Bme280

#4 Post by BertB » 19 Apr 2017, 20:07

This tgemperature deviation is most likely caused by self heating, heating by surrounding electronics and insufficient air flow.
https://ae-bst.resource.bosch.com/media ... 001-11.pdf

page 10

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 28 guests