ESP Easy Flasher

Moderators: grovkillen, Stuntteam, TD-er

Message
Author
User avatar
Ath
Normal user
Posts: 1154
Joined: 10 Jun 2018, 12:06
Location: NL

Re: ESP Easy Flasher

#151 Post by Ath » 27 Aug 2021, 13:45

mkhaled wrote: 27 Aug 2021, 04:19 I am trying to flash a wemos mini d1 with ESP_Easy_v2.0-20180321_normal_ESP8266_4096.bin and ESP_Easy_v2.0-20180321_test_ESP8266_4096 using the ESP.EASY.FLASHER gui from Grovkillen (0.04.007). It flashes fine as it shows up on my wifi as ESP_EASY_0. However, the wifi credentials (post flash action) is not working.
Is there any particular reason you are installing a ~3 1/2 year old version of ESPEasy, where there has been a new release just a few weeks ago?

It doesn't help you in finding a solution for the EspEasy Flasher issue, as that is unrelated to the ESP side of the software, it will just give a much better over-all experience, knowing to have the latest available software.
/Ton

mkhaled
Normal user
Posts: 4
Joined: 10 Mar 2021, 00:52

Re: ESP Easy Flasher

#152 Post by mkhaled » 14 Sep 2021, 21:54

Actually the only reason is that I have had good success with it. I think I will try out the new release and see how it goes.
But currently I am badly in need of finding a solution for the EspEasy Flasher issue.
Thank you for your suggestion!
Ath wrote: 27 Aug 2021, 13:45
mkhaled wrote: 27 Aug 2021, 04:19 I am trying to flash a wemos mini d1 with ESP_Easy_v2.0-20180321_normal_ESP8266_4096.bin and ESP_Easy_v2.0-20180321_test_ESP8266_4096 using the ESP.EASY.FLASHER gui from Grovkillen (0.04.007). It flashes fine as it shows up on my wifi as ESP_EASY_0. However, the wifi credentials (post flash action) is not working.
Is there any particular reason you are installing a ~3 1/2 year old version of ESPEasy, where there has been a new release just a few weeks ago?

It doesn't help you in finding a solution for the EspEasy Flasher issue, as that is unrelated to the ESP side of the software, it will just give a much better over-all experience, knowing to have the latest available software.

mkhaled
Normal user
Posts: 4
Joined: 10 Mar 2021, 00:52

Re: ESP Easy Flasher

#153 Post by mkhaled » 14 Sep 2021, 21:59

Hello and thank you for your reply. I tried flashing it again, but it still did not work. It just comes up on the wifi as ESP_EASY_0. I have seen other people have success in flashing the esp with the wifi info. If anyone has any suggestions or point me to the right direction, it would be a big help!

@Grovkillen and @TD-er thank you so much for your work! I'll make a donation. I hope you continue your work and I wish you all the very best.
TD-er wrote: 27 Aug 2021, 08:46 I think that the ESP is still preparing the file system and rebooting after you flash it.
Based on the timings, I think the flasher tries to send the commands too soon.
One way to test this theory is to flash it again, as you won't touch the file system part when flashing the bin file (except when flashing a blank image)
If it then succeeds, then I guess the flasher may need to have a slightly longer delay to send the commands.

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests