Esp8266 no web interface

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Esp8266 no web interface

#1 Post by jme » 13 Apr 2018, 19:11

Hi,

I ve tryied to upgrade a edp8266 with latest firmware but since i can t get the web interface.

It respons to ping and still send data to domoticz.

I already tried to reflash but i still can t get the interface.

How can i fix it?

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#2 Post by grovkillen » 13 Apr 2018, 19:13

Exactly what version did you upgrade to? And what version was on prior to the upgrade?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#3 Post by jme » 13 Apr 2018, 19:26

this was the previous version: ESP_Easy_mega-20180410_normal_ESP8266_4096

I've tryied to flash t this version: ESP_Easy_mega-20180413_dev_ESP8266_4096

I've reflashed with the previous version. It look like it kept the config.

I can ping it, i can see it in my router dhcp table, i can see it in my wifi status.

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#4 Post by grovkillen » 13 Apr 2018, 19:27

And have you unpowered it or not?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#5 Post by jme » 13 Apr 2018, 19:32

Yes i already unpowered it 2-3 times

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#6 Post by grovkillen » 13 Apr 2018, 19:43

Are you able to connect to a computer and do a serial monitoring?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#7 Post by jme » 13 Apr 2018, 19:50

What do you mean by serial monitoring ?

I have the arduino ide on my pc if needed.

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#8 Post by grovkillen » 13 Apr 2018, 20:00

Serial monitoring as in connecting the COM port and watch what is output in the log.

If you're on Windows you could download my flash tool (link in signature below).
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#9 Post by jme » 13 Apr 2018, 20:01

this is what i can see in the arduino ide console:

Code: Select all

WD   : Uptime 9 ConnectFailures 0 FreeMem 14304
DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
DHT  : no Reading !
DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
WD   : Uptime 10 ConnectFailures 0 FreeMem 14200
DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
WD   : Uptime 10 ConnectFailures 0 FreeMem 14096
DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
DHT  : no Reading !
DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
WD   : Uptime 11 ConnectFailures 0 FreeMem 14096
i've disconnected the temp and dht11

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#10 Post by grovkillen » 13 Apr 2018, 20:02

If you send the command "save" and then "reboot"... Does it change the behavior?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#11 Post by jme » 13 Apr 2018, 20:04

in your tools i cansee 2 com port :

CH340 and CP21x USB to UART Bridge .

Which ondo i have to use ?

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#12 Post by jme » 13 Apr 2018, 20:13

ok done:
######2018-04-13######
#######0.00.025#######
######FLASH INFO######
BIN file: ESP_Easy_mega-20180413_normal_ESP8266_4096.bin
COM port: (COM3) USB-SERIAL CH340
Baud rate: 115200
######POST FLASH######
No post flash information entered...
######FLASH LOG######
[esptool.exe -vv -cd nodemcu -cb 115200 -cp COM3 -ca 0x00000 -cf "C:\Users\séverine\Downloads\BIN\ESP_Easy_mega-20180413_normal_ESP8266_4096.bin"]
[13/04/2018 20:09:29] esptool v0.4.12 - (c) 2014 Ch. Klippel <ck@atelier-klippel.de>
[13/04/2018 20:09:29] setting board to nodemcu
[13/04/2018 20:09:29] setting baudrate from 115200 to 115200
[13/04/2018 20:09:29] setting port from to COM3
[13/04/2018 20:09:29] setting address from 0x00000000 to 0x00000000
[13/04/2018 20:09:29] espcomm_upload_file
[13/04/2018 20:09:29] espcomm_upload_mem
[13/04/2018 20:09:29] setting serial port timeouts to 1000 ms
[13/04/2018 20:09:29] opening bootloader
[13/04/2018 20:09:29] resetting board
[13/04/2018 20:09:29] trying to connect
[13/04/2018 20:09:29] flush start
[13/04/2018 20:09:29] setting serial port timeouts to 1 ms
[13/04/2018 20:09:29] setting serial port timeouts to 1000 ms
[13/04/2018 20:09:29] flush complete
[13/04/2018 20:09:29] espcomm_send_command: sending command header
[13/04/2018 20:09:29] espcomm_send_command: sending command payload
[13/04/2018 20:09:29] read 0, requested 1
[13/04/2018 20:09:29] trying to connect
[13/04/2018 20:09:29] flush start
[13/04/2018 20:09:29] setting serial port timeouts to 1 ms
[13/04/2018 20:09:29] setting serial port timeouts to 1000 ms
[13/04/2018 20:09:29] flush complete
[13/04/2018 20:09:29] espcomm_send_command: sending command header
[13/04/2018 20:09:29] espcomm_send_command: sending command payload
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] Uploading 666736 bytes from C:\Users\séverine\Downloads\BIN\ESP_Easy_mega-20180413_normal_ESP8266_4096.bin to flash at 0x00000000
[13/04/2018 20:09:29] erasing flash
[13/04/2018 20:09:29] size: 0a2c70 address: 000000
[13/04/2018 20:09:29] first_sector_index: 0
[13/04/2018 20:09:29] total_sector_count: 163
[13/04/2018 20:09:29] head_sector_count: 16
[13/04/2018 20:09:29] adjusted_sector_count: 147
[13/04/2018 20:09:29] erase_size: 093000
[13/04/2018 20:09:29] espcomm_send_command: sending command header
[13/04/2018 20:09:29] espcomm_send_command: sending command payload
[13/04/2018 20:09:29] setting serial port timeouts to 15000 ms
[13/04/2018 20:09:29] setting serial port timeouts to 1000 ms
[13/04/2018 20:09:29] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:09:29] writing flash
[13/04/2018 20:09:37] ................................................................................ [ 12% ]
[13/04/2018 20:09:45] ................................................................................ [ 24% ]
[13/04/2018 20:09:53] ................................................................................ [ 36% ]
[13/04/2018 20:10:01] ................................................................................ [ 49% ]
[13/04/2018 20:10:09] ................................................................................ [ 61% ]
[13/04/2018 20:10:17] ................................................................................ [ 73% ]
[13/04/2018 20:10:25] ................................................................................ [ 85% ]
[13/04/2018 20:10:33] ................................................................................ [ 98% ]
[13/04/2018 20:10:34] ............ [ 100% ]
[13/04/2018 20:10:34] starting app without reboot
[13/04/2018 20:10:34] espcomm_send_command: sending command header
[13/04/2018 20:10:34] espcomm_send_command: sending command payload
[13/04/2018 20:10:34] espcomm_send_command: receiving 2 bytes of data
[13/04/2018 20:10:34] closing bootloader
[13/04/2018 20:10:34] flush start
[13/04/2018 20:10:34] setting serial port timeouts to 1 ms
[13/04/2018 20:10:34] setting serial port timeouts to 1000 ms
[13/04/2018 20:10:34] flush complete
[2018-04-13 20:10:34] DONE!
############################
[2018-04-13 20:10:34] JOB COMPLETED, over and out!

Code: Select all

INIT : Booting version: mega-20180413
60 : INIT : Warm boot #2
61 : FS   : Mounting...
86 : FS   : Mount successful, used 75802 bytes of 957314
376 : CRC  : program checksum       ...OK
384 : CRC  : Settings CRC           ...FAIL
387 : CRC  : SecuritySettings CRC   ...OK
488 : INIT : Free RAM:18032
489 : INIT : I2C
489 : INIT : SPI not enabled
1315 : WIFI : Connecting FRITZ attempt #0
1321 : WD   : Uptime 0 ConnectFailures 0 FreeMem 15024
1345 : DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
2342 : DHT  : no Reading !
3459 : WIFI : Connected! AP: FRITZ (24:65:11:90:69:B6) Ch: 1 Duration: 2143 ms
4102 : WIFI : DHCP IP: 192.168.1.64 (ESP-Easy-Piscine-0) GW: 192.168.1.1 SN: 255.255.255.0   duration: 643 ms
22344 : DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
31321 : WD   : Uptime 1 ConnectFailures 0 FreeMem 15080
42343 : DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
61321 : WD   : Uptime 1 ConnectFailures 0 FreeMem 14736
62343 : DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
62365 : DHT  : no Reading !
64325 : WIFI : AP Mode Disabled for SSID: ESP_Easy_Piscine_0
64326 : WIFI : Set WiFi to STA
64340 : WIFI : Disconnected! Reason: 'Assoc leave' Connected for 1 m 0 s
64341 : WIFI : Connecting FRITZ attempt #0
64470 : WIFI : Connected! AP: FRITZ (24:65:11:90:69:B6) Ch: 1 Duration: 128 ms
65348 : WIFI : DHCP IP: 192.168.1.64 (ESP-Easy-Piscine-0) GW: 192.168.1.1 SN: 255.255.255.0   duration: 878 ms
82345 : DS   : Temperature: Error! (28-8a-fe-27-0-0-80-45)
91321 : WD   : Uptime 2 ConnectFailures 0 FreeMem 15848

still same issue.

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#13 Post by grovkillen » 13 Apr 2018, 20:15

Do you have two units connected? Both those programmers are used by ESP-units. CHxxxx is generally used by NodeMCU and the and CPxxxx is generally used by Wemos.


EDIT: seems like the problem is the settings file. If you could use your arduino IDE and send the command "save" to see if that will re-initiate the settings file..
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#14 Post by jme » 13 Apr 2018, 20:33

Will test it later on i had to move.

If neded we can reset the config.

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#15 Post by grovkillen » 13 Apr 2018, 20:36

If you are all right with wiping the settings you could use these "null" bin files before doing a real flash with a real bin.
Attachments
Blank_BINs.zip
(6.32 KiB) Downloaded 92 times
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

jme
Normal user
Posts: 33
Joined: 11 Apr 2018, 14:20

Re: Esp8266 no web interface

#16 Post by jme » 13 Apr 2018, 22:19

it did the trick, the esp is recover and work again.

Thx

User avatar
grovkillen
Core team member
Posts: 3438
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp8266 no web interface

#17 Post by grovkillen » 13 Apr 2018, 22:35

Great! :)
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests