Wemos D1 Mini running Arduino can't flash with ESP Easy

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
whatsupskip
Normal user
Posts: 92
Joined: 28 Feb 2018, 07:40

Wemos D1 Mini running Arduino can't flash with ESP Easy

#1 Post by whatsupskip » 09 May 2018, 06:28

I am fairly sure I have done this before. Taken a Wemos D1 Mini (clone V1.0) that is running a simple Arduino sketch and flashed it with ESP Easy.

I think I am missing something very obvious here.

I have tried three different firmware versions:
mega-20180507 Dev 4096
mega-20180316 Dev 4096
v2.0-20180227_normal_ESP8266_4096

I seem to recall having problems with flashing some Wemos D1 Mini before, but I can't remember what I did, other than retry.

All I am doing is plugging into a USB 2.0 port on Windows 7 Pro computer and running the FlashESP8266.exe file that is in the same folder as the bin file. Then restarting the Wemos D1 Mini.

User avatar
demonchok
Normal user
Posts: 19
Joined: 03 May 2018, 15:29
Location: Ballerup, Denmark
Contact:

Re: Wemos D1 Mini running Arduino can't flash with ESP Easy

#2 Post by demonchok » 11 May 2018, 18:09

what error comes up ? on some nodemcus there is a flash button u must press
"Don't let hope become a memory"

Domosapiens
Normal user
Posts: 286
Joined: 06 Nov 2016, 13:45

Re: Wemos D1 Mini running Arduino can't flash with ESP Easy

#3 Post by Domosapiens » 11 May 2018, 18:37

USB 2.0 port on Windows 7
Good enough for flash, but not enough power for running.
That's my experience.
Did you try a separate 5V 1Amp power supply?
30+ ESP units for production and test. Ranging from control of heating equipment, flow sensing, floor temp sensing, energy calculation, floor thermostat, water usage, to an interactive "fun box" for my grandson. Mainly Wemos D1.

TD-er
Core team member
Posts: 1603
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Wemos D1 Mini running Arduino can't flash with ESP Easy

#4 Post by TD-er » 12 May 2018, 21:36

Try decent USB cables and if possible use an USB3 port. Those can deliver a bit more. (900 mA vs 500 mA)
If your board has a flash button, keep the flash button pressed the whole time during flash and press reset once (hold the flash pressed) then start flashing.

whatsupskip
Normal user
Posts: 92
Joined: 28 Feb 2018, 07:40

Re: Wemos D1 Mini running Arduino can't flash with ESP Easy

#5 Post by whatsupskip » 12 May 2018, 23:39

I don't think it is a power or USB cable issue as I have been able to flash other Wemos D1 Mini with the same cables.

I did try configuring some of the GPIO to force it into flash mode.

I haven't tried the reset button. I will try this next.

Thanks for all your suggestions.

whatsupskip
Normal user
Posts: 92
Joined: 28 Feb 2018, 07:40

Re: Wemos D1 Mini running Arduino can't flash with ESP Easy

#6 Post by whatsupskip » 31 Oct 2018, 22:13

Just an update on this. I was able to flash the Wemos D1 mini with the blank 4MB image and then flash with one of the dev versions. This worked well in the end.

Thanks again to the developers for adding this additional feature.

Post Reply

Who is online

Users browsing this forum: No registered users and 29 guests