EasyESP lost connection to MQTT server

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
mackowiakp
Normal user
Posts: 98
Joined: 07 Jun 2018, 06:47

EasyESP lost connection to MQTT server

#1 Post by mackowiakp » 07 Aug 2018, 13:33

I have four EasyESP based units. All of them works with Domoticz, 3 via MQTT Mosquitto broker and one via Domoticz HTTP. All units using the last available on Github FW, that is Release mega-20180804. The problem is that MQTT based units, lost connection to server - netstat shows that co IP connection is established - but it is possible to login to such unit over WEB and after soft reboot from menu, it works properly next several hours. What the problem it shuld be? Below my mosquitto config file:

Code: Select all

pid_file /var/run/mosquitto.pid
persistence true
persistence_location /var/lib/mosquitto/
log_dest none
#log_dest file /var/log/mosquitto/mosquitto.log
include_dir /etc/mosquitto/conf.d
max_queued_messages 200
message_size_limit 0
allow_anonymous true 
autosave_interval 900
autosave_on_changes false
allow_zero_length_clientid true
allow_duplicate_messages false
persistence_file mosquitto.db
password_file /etc/mosquitto/passwd

TD-er
Core team member
Posts: 1374
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: EasyESP lost connection to MQTT server

#2 Post by TD-er » 07 Aug 2018, 22:21

You could have a look at the sysinfo page and check the IP-address reported there. (when MQTT connection is lost again)
If it is 0.0.0.0, then it is something reported before, but still not known what is causing it.

mackowiakp
Normal user
Posts: 98
Joined: 07 Jun 2018, 06:47

Re: EasyESP lost connection to MQTT server

#3 Post by mackowiakp » 08 Aug 2018, 10:27

So I switch all units to Domoticz HTTP and it works correctly over 2 days.

waspie
Normal user
Posts: 110
Joined: 09 Feb 2017, 19:35

Re: EasyESP lost connection to MQTT server

#4 Post by waspie » 08 Aug 2018, 21:42

My units have been dropping MQTT about once a day for many days now but I've never checked for the 0.0.0.0
at least with the mqtt#connected i can alert openhab to resend commands.

you're not alone

Post Reply

Who is online

Users browsing this forum: No registered users and 20 guests