Still a little help needed / HTTP send command

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Sasch600xt
Normal user
Posts: 62
Joined: 10 Sep 2018, 16:37

Still a little help needed / HTTP send command

#1 Post by Sasch600xt » 28 Sep 2018, 21:34

hello all :)

i am still a little fighting on my side here.

Could someone give this a try with a newer version like 201809xx :

Code: Select all

on System#Boot do
Monitor GPIO,0
Monitor GPIO,4
Monitor GPIO,5
Monitor GPIO,16
timerSet,1,30
endon

on GPIO#16=1 do
    SendToHTTP 192.168.123.10,8080,/json.htm?type=command&param=switchlight&idx=17&switchcmd=On
endon

on GPIO#16=0 do
    SendToHTTP 192.168.123.10,8080,/json.htm?type=command&param=switchlight&idx=17&switchcmd=Off
endon
I do not even get a message to receiv.
With 20180826 i get "GET /json.htm?type=command¶m=switchlight&idx=17&switchcmd=Off" wich i can work with and all is fine.
After posting all my trouble in here, TD-er gave me a hint my receiver script for php is not a very good code.
So a friend and mine designed the receiver script new from scratch. Then i tryed newer images as 20180826 and i dont even get a message from ESP-Easy.

So now i am not sure it is only the falt of my receiver scripts.
I do not get any raw HTTP messages with higher the 20180826.

No controller user and no password is in use.
Can this maybe the problem ?

Hardware is nodemcu lolin V3
image "normal,4096"

Thank you for your help!

Sascha

User avatar
grovkillen
Core team member
Posts: 3144
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Still a little help needed / HTTP send command

#2 Post by grovkillen » 28 Sep 2018, 22:38

If you try this command in the command line on the tools page:

Code: Select all

SendToHTTP 192.168.123.10,8080,/json.htm?type=command&param=switchlight&idx=17&switchcmd=On
Do you still not get a message sent?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

Sasch600xt
Normal user
Posts: 62
Joined: 10 Sep 2018, 16:37

Re: Still a little help needed / HTTP send command

#3 Post by Sasch600xt » 28 Sep 2018, 23:01

thank you for your answere.

this worked once and i got the message (one step further)
but after the command the ESP freezed and i had to do a hard reset.

Sascha

EDIT: i did it a few times and always after send the command from tools form the ESP freezed.

User avatar
grovkillen
Core team member
Posts: 3144
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Still a little help needed / HTTP send command

#4 Post by grovkillen » 28 Sep 2018, 23:28

You should open a issue on GitHub. Sounds like a bug
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests