Page 1 of 1

UDP Controller only sending first value

Posted: 26 Feb 2019, 11:18
by mikeO
I am using a UDP controller to send values from a generic dummy device. The device is receiving data sent from a micro (processing Anemometer sensor ) via a TaskVaueSet command, 3 values are sent and received by the device. The UDP controller however is only sending the first value. I have read a post from October 2018 where I understood this behavior was fixed, unfortunately I don't seem to be able to find this post again now. I am just new and enjoying using ESP Easy but the controller is just not working for me. I have the latest build.

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 11:46
by grovkillen
What settings do you have for the controller?

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 12:33
by mikeO
Hi, thanks for your reply, controller setup attached.
2019-02-26 22_19_40-Clipboard.jpg
2019-02-26 22_19_40-Clipboard.jpg (130.24 KiB) Viewed 2406 times

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 13:06
by grovkillen
There you have it, max queue depth. Change that to 10.

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 13:40
by mikeO
I have changed that back to 10, I think that was the original default value but the fields sent are just repeats of the value1.
I have found the post I was refering to, it describes in there are exactly what i am seeing, at the end of the post it is declared fixed but I don't see that?

https://github.com/letscontrolit/ESPEasy/issues/1891

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 13:56
by grovkillen
Please use that GitHub thread to further add to the issue. You may also copy the link to this thread for reference.

Re: UDP Controller only sending first value

Posted: 26 Feb 2019, 15:10
by TD-er
Why are you using such a long interval between messages? (Minimum Send Interval)
For internal communications 10 msec is often just fine.
Also the timeout can be set a bit lower, if the receiving end is up for it (also take into account the network latency)

How is the Dummy device configured?

Re: UDP Controller only sending first value

Posted: 27 Feb 2019, 03:49
by mikeO
OK, its now working. I had not understood the significance of Simulate data Type: in the Device setup. I have 3 TaskValues being sent so setting the "type" to "Sensor_type_triple" solved the issue. Thanks for the quick assistance.

Re: UDP Controller only sending first value

Posted: 14 Apr 2019, 19:59
by Patou
Hello
I have same problem and cannot find what i am doing wrong ...
Here is config of first esp config of second esp is identical
2019-04-14_18h54_29.png
2019-04-14_18h54_29.png (21.8 KiB) Viewed 2158 times
Config of UDP controller same in the 2 Esp :
2019-04-14_19h09_08.png
2019-04-14_19h09_08.png (18.03 KiB) Viewed 2158 times
I use dummy device in task 12
2019-04-14_19h11_01.png
2019-04-14_19h11_01.png (5.28 KiB) Viewed 2158 times
In the tutorial it is indicated that the task that is shared via udp is created automatically in all the participant esp units
But this is not the case in my application
Also when I create a task in the other unit and share it over upd controller the values are not updated
See below the setting of task 12 in one of the units
2019-04-14_19h53_27.png
2019-04-14_19h53_27.png (17.45 KiB) Viewed 2158 times
Can an advanced user explain what I do wrong
Thanks in advance
Patrou

Re: UDP Controller only sending first value

Posted: 14 Apr 2019, 20:03
by grovkillen
ESP Easy P2P is "automatically" detected and if you want the devices to share data you need to address that in the advanced settings menu...

Re: UDP Controller only sending first value

Posted: 14 Apr 2019, 20:06
by Patou
hello
Thanks for your quick reaction
I found only this in the advanced settings
2019-04-14_20h05_29.png
2019-04-14_20h05_29.png (2.25 KiB) Viewed 2155 times
Is this what you means ?
Patou

Re: UDP Controller only sending first value

Posted: 14 Apr 2019, 23:08
by Domosapiens
Correct, that's the port setting.
Additional choose under the tab Controllers the ESPEasy P2P Networking.

It's somewhat legacy that activation and port setting are on different places.

Re: UDP Controller only sending first value

Posted: 15 Apr 2019, 10:28
by Patou
OK thanks
found my error
I choose generic udp controller instead of p2p udp
Thanks for your help
Patou