Wifi seems to be dead.. how to get the config (r120)

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
dannybloe
Normal user
Posts: 36
Joined: 16 Dec 2015, 16:29

Wifi seems to be dead.. how to get the config (r120)

#1 Post by dannybloe » 26 Mar 2019, 17:49

Howdee folks,

Of all my ESPEasy's in my house there is one running old r120 software and no backup. Turns out it won't connect to wifi anymore but it seems it still runs. I can connect to it using the serial interface and indeed it seems it cannot find any ssids so I assume the wifi of the board (Lolin) is dead.

So my question is: is there a way to get to the config? The rules and the pin config? Or are there any other ways to get to my stuff?

Help is greatly appreciated!

Cheers,
Danny

Domosapiens
Normal user
Posts: 291
Joined: 06 Nov 2016, 13:45

Re: Wifi seems to be dead.. how to get the config (r120)

#2 Post by Domosapiens » 26 Mar 2019, 23:21

My guess:

.... the 49 day bug ???
In those days there was a counter that went wrong.
A re-boot within the 49 day time-frame was the solution (make a rule).
or ... as for now, power off & on is the only way to get the Wifi connection back.
30+ ESP units for production and test. Ranging from control of heating equipment, flow sensing, floor temp sensing, energy calculation, floor thermostat, water usage, to an interactive "fun box" for my grandson. Mainly Wemos D1.

dannybloe
Normal user
Posts: 36
Joined: 16 Dec 2015, 16:29

Re: Wifi seems to be dead.. how to get the config (r120)

#3 Post by dannybloe » 27 Mar 2019, 06:51

Unfortunately that doesn't work. I rebooted the thing several times (remove power) and that didn't work. I do get serial connection but I have no idea how to get some useful information from the esp. Thing is that it had some unusual pin-configurations and I kinda forgot what it was :?

Hence my question if there is any way to get the config off the board in someway.

Still weird it doesn't want to connect to wifi anymore...

User avatar
ThomasB
Normal user
Posts: 406
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Wifi seems to be dead.. how to get the config (r120)

#4 Post by ThomasB » 28 Mar 2019, 20:39

If you can backup the entire ROM then you can migrate to working hardware. So something like this is worth a shot:
viewtopic.php?t=5169

But, maybe WiFi is working and the STA mode settings are corrupted. That would probably cause ESPEasy fallback to AP mode. Have you checked that?
https://www.letscontrolit.com/wiki/index.php/EasySetup

- Thomas

dannybloe
Normal user
Posts: 36
Joined: 16 Dec 2015, 16:29

Re: Wifi seems to be dead.. how to get the config (r120)

#5 Post by dannybloe » 31 Mar 2019, 17:00

Thanks a lot Thomas, that worked like a charm!

Danny

User avatar
ThomasB
Normal user
Posts: 406
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Wifi seems to be dead.. how to get the config (r120)

#6 Post by ThomasB » 31 Mar 2019, 17:28

You're welcome. Glad to hear you solved it. Which method did you fix it with, backup migration or WiFi AP mode?

- Thomas

dannybloe
Normal user
Posts: 36
Joined: 16 Dec 2015, 16:29

Re: Wifi seems to be dead.. how to get the config (r120)

#7 Post by dannybloe » 31 Mar 2019, 19:06

The backup as wifi is not working anymore, including AP mode.

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests