error

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Dos
Normal user
Posts: 6
Joined: 26 Jan 2018, 21:33

error

#1 Post by Dos » 23 Jan 2021, 01:39

I try to use ESP easy wit home Assistant , but i cannot get it working

Image

but still nothing at Mqtt, al logging i have this
632324: WD : Uptime 11 ConnectFailures 0 FreeMem 17432 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
662325: WD : Uptime 11 ConnectFailures 0 FreeMem 20856 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
662989: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
663569: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
692324: WD : Uptime 12 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
722324: WD : Uptime 12 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
722993: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
723573: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
752325: WD : Uptime 13 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
782325: WD : Uptime 13 ConnectFailures 0 FreeMem 20624 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
783000: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
783577: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
812325: WD : Uptime 14 ConnectFailures 0 FreeMem 20576 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
842324: WD : Uptime 14 ConnectFailures 0 FreeMem 20544 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
843002: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
843582: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
872324: WD : Uptime 15 ConnectFailures 0 FreeMem 20544 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
902325: WD : Uptime 15 ConnectFailures 0 FreeMem 20544 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
903007: DS : Temperature: 0.9 (28-aa-20-91-4b-14-01-62 [DS18B20])

i works with Domoticz , but not with HA

does somboday know what these failures mean en what settnig is still wrong?
Attachments
Naamloos.jpg
Naamloos.jpg (94.27 KiB) Viewed 932 times

TD-er
Core team member
Posts: 4254
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: error

#2 Post by TD-er » 23 Jan 2021, 01:55

I can't see the first screenshot, maybe because it has the same filename "Naamloos" ?

In the logs I don't see any error.

Just to make sure as it is not part of the screenshot.
You do have the controller enabled?
And it is also selected in the tasks you want to send to HA?
You mention Domoticz MQTT. Make sure you only have a single MQTT controller active as we currently don't support 2 active MQTT controllers.

I do see the topics you're subscribing to and publishing to do have a leading slash.
Make sure your HA setup also requires a leading slash in the topics.
It is a bit 'strange' to have a leading slash in MQTT topics as it means its first level is one with no name (""), so it is better to not start with a slash.
It will still work though, as long as all clients connecting to the broker use the same topic structure.

Dos
Normal user
Posts: 6
Joined: 26 Jan 2018, 21:33

Re: error

#3 Post by Dos » 23 Jan 2021, 09:53

It is not really an error , sorry for the unclear note. but it is the message what is not clear at the logging: ConnectFailures 0 FreeMem

29522325: WD : Uptime 492 ConnectFailures 0 FreeMem 20184 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init

i updated to the lates espeasy firmware : ESP_Easy_mega_20210114_dev_ESP8266_4M1M in my nodeNCU v2

I used it for some years ayt domoticz. all date is send with idx 2xtemperature sensors and 1x lux sensor
and at MQTT explorer i see at topic domoticz/in
{"idx":231,"RSSI":8,"nvalue":0,"svalue":"37.6"}
{"idx":212,"RSSI":8,"nvalue":0,"svalue":"9.1"}
{"idx":231,"RSSI":8,"nvalue":0,"svalue":"37.6"}

also Domoticz is reading the values . it is working

But now i want to switch to HA..

and yes i disabled teh domottixz MQTT controller and enabled the openHAB MQTT controller

but when i check with MQTT explorer, i see no message anymore appear
only at topic home/nodeMCU v2/status/LWT = connected

i changed:
Controller Subscribe: home/%sysname%/# (instead of /%sysname%/#)
Controller Publish: home/%sysname%/%tskname%/%valname% (instead of /%sysname%/%tskname%/%valname%)



when i check logging i see 2 temperature sensor,(DS18B20) but where is the third sensor (lux sensor) that one is connected to i2C Analog input - ADS1115


32324: WD : Uptime 11 ConnectFailures 0 FreeMem 17432 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
662325: WD : Uptime 11 ConnectFailures 0 FreeMem 20856 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
662989: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
663569: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
692324: WD : Uptime 12 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
722324: WD : Uptime 12 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
722993: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
723573: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])
752325: WD : Uptime 13 ConnectFailures 0 FreeMem 20672 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
782325: WD : Uptime 13 ConnectFailures 0 FreeMem 20624 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
783000: DS : Temperature: 1.0 (28-aa-20-91-4b-14-01-62 [DS18B20])
783577: DS : Temperature: 11.1 (28-aa-b5-62-40-14-01-3f [DS18B20])

User avatar
Ath
Normal user
Posts: 561
Joined: 10 Jun 2018, 12:06
Location: NL

Re: error

#4 Post by Ath » 23 Jan 2021, 10:19

Dos wrote: 23 Jan 2021, 09:53 It is not really an error , sorry for the unclear note. but it is the message what is not clear at the logging: ConnectFailures 0 FreeMem

29522325: WD : Uptime 492 ConnectFailures 0 FreeMem 20184 WiFiStatus 3 ESPeasy internal wifi status: Conn. IP Init
That's not an error, but the WatchDog (WD) reporting its status.
You should read it from left to right
Uptime 492
ConnectFailures 0
FreeMem 20184
WiFiStatus 3
ESPeasy internal wifi status: Conn. IP Init


You expect temperatures to be sent over MQTT to both Domoticz and HA, well, I think the current limit is that only 1 active MQTT Controller is supported at the same time.

You could try to switch Domoticz to the HTTP controller (most settings should stay the same, except it doesn't communicate over MQTT), so HA is the only MQTT controller.
/Ton

Dos
Normal user
Posts: 6
Joined: 26 Jan 2018, 21:33

Re: error

#5 Post by Dos » 23 Jan 2021, 12:16

Aah ok it meens

zero ConnectFailures ok.

I known it supports only one controller at the same time . So i really did disable Domoticz MQTT and enable openHAB MQTT
Image
Attachments
Naamloos1.png
Naamloos1.png (13.95 KiB) Viewed 912 times

Dos
Normal user
Posts: 6
Joined: 26 Jan 2018, 21:33

Re: error

#6 Post by Dos » 24 Jan 2021, 07:41

Yes finial I god it working
It is now sending a topic with a value

User avatar
Ath
Normal user
Posts: 561
Joined: 10 Jun 2018, 12:06
Location: NL

Re: error

#7 Post by Ath » 24 Jan 2021, 10:32

Can you share what's changed to get it working?
/Ton

Dos
Normal user
Posts: 6
Joined: 26 Jan 2018, 21:33

Re: error

#8 Post by Dos » 24 Jan 2021, 14:59

i Did not know there where also settings to be made at each sensor
Send to Controller nr

i made controller 2 for HA and deactivate controller 1 , so data was not send to controller 2

Post Reply

Who is online

Users browsing this forum: No registered users and 23 guests