TSOP4838 IR Input. different values for on/off normal?

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

TSOP4838 IR Input. different values for on/off normal?

#1 Post by tozett » 02 Feb 2016, 21:28

i hooked up a TSOP4838 on GPIO12 with R076.
i press one button on my samsung or Pioneer remote, i see a sequenz for this single button of the remote.
also i would like to send the "code" with the http-request/push template, not only the float ? "value" (because the code is shorter).
do i have to configure something more?

is this normal, that the remote sends one code for the button-press, and another arbitrary for release?
the "press"-code seems the same, the "release"-code seems to change..

this is two time the on/off=press/release sequence of the same button (info) on my samsung remote:

Code: Select all

Feb  2 21:21:26 ESP Unit: 0 : HTTP : closing connection
PRESS -- Feb  2 21:21:32 ESP Unit: 0 : IR   : Code e0e0f807
Feb  2 21:21:32 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:32 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=3772839936.00
Feb  2 21:21:32 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:32 ESP Unit: 0 : IR   : Code a6240345
Feb  2 21:21:32 ESP Unit: 0 : HTTP : Delay 1000 ms
Feb  2 21:21:33 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:33 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=2787377920.00
Feb  2 21:21:33 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:36 ESP Unit: 0 : DS   : Temperature: 23.87 (28-ff-dd-f0-4c-4-0-3a)
Feb  2 21:21:36 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:36 ESP Unit: 0 : /esp01?device=sw13?device=&param=Temperature&value=23.87
Feb  2 21:21:36 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:46 ESP Unit: 0 : DS   : Temperature: 23.94 (28-ff-dd-f0-4c-4-0-3a)
Feb  2 21:21:46 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:46 ESP Unit: 0 : /esp01?device=sw13?device=&param=Temperature&value=23.94
Feb  2 21:21:46 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:46 ESP Unit: 0 : WD   : Uptime 6 ConnectFailures 0 FreeMem 24888
Feb  2 21:21:46 ESP Unit: 0 : UDP  : Send Sysinfo message
PRESS -- Feb  2 21:21:49 ESP Unit: 0 : IR   : Code e0e0f807
Feb  2 21:21:49 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:49 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=3772839936.00
Feb  2 21:21:50 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:50 ESP Unit: 0 : IR   : Code 49f3e444
Feb  2 21:21:50 ESP Unit: 0 : HTTP : Delay 1000 ms
Feb  2 21:21:50 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:50 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=1240720512.00
Feb  2 21:21:51 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:21:56 ESP Unit: 0 : DS   : Temperature: 23.87 (28-ff-dd-f0-4c-4-0-3a)
Feb  2 21:21:56 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:21:56 ESP Unit: 0 : /esp01?device=sw13?device=&param=Temperature&value=23.87
Feb  2 21:21:56 ESP Unit: 0 : HTTP : closing connection
this is the same button from my pioneer remote:

Code: Select all

Feb  2 21:23:56 ESP Unit: 0 : HTTP : closing connection
PRESS -- Feb  2 21:24:00 ESP Unit: 0 : IR   : Code fc200794
Feb  2 21:24:00 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:00 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=4229957632.00
Feb  2 21:24:01 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:24:01 ESP Unit: 0 : IR   : Code 8a87cad4
Feb  2 21:24:01 ESP Unit: 0 : HTTP : Delay 1000 ms
Feb  2 21:24:01 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:01 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=2324155136.00
Feb  2 21:24:02 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:24:06 ESP Unit: 0 : DS   : Temperature: 23.87 (28-ff-dd-f0-4c-4-0-3a)
Feb  2 21:24:06 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:06 ESP Unit: 0 : /esp01?device=sw13?device=&param=Temperature&value=23.87
Feb  2 21:24:06 ESP Unit: 0 : HTTP : closing connection
PRESS -- Feb  2 21:24:13 ESP Unit: 0 : IR   : Code fc200794
Feb  2 21:24:13 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:13 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=4229957632.00
Feb  2 21:24:13 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:24:13 ESP Unit: 0 : IR   : Code 105f71ef
Feb  2 21:24:13 ESP Unit: 0 : HTTP : Delay 1000 ms
Feb  2 21:24:14 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:14 ESP Unit: 0 : /esp01?device=sw13?device=&param=IR&value=274690528.00
Feb  2 21:24:14 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:24:16 ESP Unit: 0 : DS   : Temperature: 23.94 (28-ff-dd-f0-4c-4-0-3a)
Feb  2 21:24:16 ESP Unit: 0 : HTTP : connecting to 192.168.14.253
Feb  2 21:24:16 ESP Unit: 0 : /esp01?device=sw13?device=&param=Temperature&value=23.94
Feb  2 21:24:16 ESP Unit: 0 : HTTP : closing connection
Feb  2 21:24:16 ESP Unit: 0 : WD   : Uptime 8 ConnectFailures 0 FreeMem 24888
Feb  2 21:24:16 ESP Unit: 0 : UDP  : Send Sysinfo message

tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

Re: TSOP4838 IR Input. different values for on/off normal?

#2 Post by tozett » 02 Feb 2016, 21:32

i tried to test it again after posting, but now it seems to get noise from the IR. is this possible?
its configured with the default device setting "pull-up". maybe wrong?

tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

Re: TSOP4838 IR Input. different values for on/off normal?

#3 Post by tozett » 03 Feb 2016, 19:48

i recognized some erratic receives, where no remote was sending anything.
i cannot really code something, but google 8-)
and if found this pieces, which led me to a
+1 Feature-Request: give out the recognized remote (sony/sanyo/technics..)
+1 Feature-Request: IR-Send (sometime?)

https://github.com/juanpintom/Souliss_E ... Receiver.h
http://internetofhomethings.com/homethings/?p=899

tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

Re: TSOP4838 IR Input. different values for on/off normal?

#4 Post by tozett » 03 Feb 2016, 20:20

i looked like a "drift" in the receiving quality over time.
i cold-reset the ESP. than i took two different small remotes and got clear readings.
and always 1 code for 1 button.
i exchanged the batteries of the technics remote.
i got clear readings (after the cold-reboot) with the technics-remote
still 1 code for the button-press, and another abitrary for the release.
the same with some buttons of my samsung-remote.
with the "GUIDE" button i got abritrary codes on button press and on release.
so far, so good
Attachments
ir2.png
ir2.png (241.1 KiB) Viewed 3127 times

tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

Re: TSOP4838 IR Input. different values for on/off normal?

#5 Post by tozett » 04 Feb 2016, 07:39

just to fill the record:
i got clear readings after an uptime of 600+ minutes...
but actually i am in a dark environment...
so there is maybe no "drift" but irritation through "scattered light" in the evening, when all lights an on in the room.
i will check this, if i maybee need a box around the small IR-receiver

Deennoo
Normal user
Posts: 158
Joined: 07 Sep 2015, 13:03

Re: TSOP4838 IR Input. different values for on/off normal?

#6 Post by Deennoo » 21 Feb 2016, 12:05

I'm on it to, will try on a box, because openspace rive lot of flase code.

Deennoo
Normal user
Posts: 158
Joined: 07 Sep 2015, 13:03

Re: TSOP4838 IR Input. different values for on/off normal?

#7 Post by Deennoo » 23 Feb 2016, 23:00

Made some test with ans without box, and with 2 differents IR reciever results are the same, to much false code to be usable.

Maybe a learning méthode have to be done like LIRC do (only the first part), just to reconize which protocole have to be use.

tozett
Normal user
Posts: 733
Joined: 22 Dec 2015, 15:46
Location: Germany

Re: TSOP4838 IR Input. different values for on/off normal?

#8 Post by tozett » 24 Feb 2016, 07:26

i had a lot of false readings because of weak batteries in two of my remotes.
maybe usefull to try again with fresh batteries?

Deennoo
Normal user
Posts: 158
Joined: 07 Sep 2015, 13:03

Re: TSOP4838 IR Input. different values for on/off normal?

#9 Post by Deennoo » 24 Feb 2016, 07:33

OK will try.

But i don't have any problème with LIRC.

Deennoo
Normal user
Posts: 158
Joined: 07 Sep 2015, 13:03

Re: TSOP4838 IR Input. different values for on/off normal?

#10 Post by Deennoo » 24 Feb 2016, 14:05

I'm back with new battery and a real TSOP4838 (on previous test i use a HSIR38S2 stolen from an old hifi parts)...

Have to admit that it is really better, but sometime false code still appear.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests