Esp Easy and Wemos Motor Shield

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Esp Easy and Wemos Motor Shield

#1 Post by giobbe » 21 Mar 2017, 11:08

Hi,
I would use the Wemos motor shield (https://www.wemos.cc/product/motor-shield.html) with easy esp. I tried to insert the library in esp easy but it does not work. You can help me?
Thank you
Giobbe

krikk
Normal user
Posts: 115
Joined: 28 Feb 2017, 07:57
Location: Austria
Contact:

Re: Esp Easy and Wemos Motor Shield

#2 Post by krikk » 21 Mar 2017, 21:53

without coding there is no support for this shield, we have support for the adafruit motorshield v2 currently

..but as this shield is also i2c based it should be pretty simple to write a plugin for it...

giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Re: Esp Easy and Wemos Motor Shield

#3 Post by giobbe » 22 Mar 2017, 09:28

that soon it would be nice make plugin for Wemos Motor Shield,
as it is very common
This is a arduino library: https://github.com/wemos/WEMOS_Motor_Sh ... no_Library
Thanks

giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Re: Esp Easy and Wemos Motor Shield

#4 Post by giobbe » 04 Apr 2017, 09:08

up

giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Re: Esp Easy and Wemos Motor Shield

#5 Post by giobbe » 11 Apr 2017, 09:33

Re-Up....
:cry:

krikk
Normal user
Posts: 115
Joined: 28 Feb 2017, 07:57
Location: Austria
Contact:

Re: Esp Easy and Wemos Motor Shield

#6 Post by krikk » 11 Apr 2017, 10:11

this wont help...

3 option:
  1. do it yourself, doku for development is on the wiki...
  2. find someone who codes it for you...
  3. wait and hope that someone with coding skills and this motorshield write a plugin

giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Re: Esp Easy and Wemos Motor Shield

#7 Post by giobbe » 29 Apr 2017, 23:14

up

giobbe
Normal user
Posts: 12
Joined: 20 Mar 2017, 10:29

Re: Esp Easy and Wemos Motor Shield

#8 Post by giobbe » 19 Feb 2018, 16:01

UP

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#9 Post by TungstenE2 » 15 May 2018, 19:12

Hi, did you find a solution?
I would also like to use the wemos motor shield with ESPeasy mega latest build.

thx

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#10 Post by TungstenE2 » 15 May 2018, 19:29

Hi krikk,

I found your Plugin P048_Motorshield_v2.ino when I was searching for setup of Wemos Motorshield with Wemos D1 mini running ESPeasy mega latest version.

Is there a way to use your plugin for Adafruit Motorshield with Wemos Motorshield? If not, is there an other way to use the Wemos Motorshield without dedicated plugin?

I am new to ESPeasy and I am not a developer.

thx Tungsten


https://www.letscontrolit.com/wiki/inde ... lugin_list

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#11 Post by TungstenE2 » 22 May 2018, 21:56

Hi all,

I have set up Wemos D1 mini and Motorshield using latest ESPeasy test version.

Setup up according to Plugin48 documentation using Hex 0x30.

https://www.letscontrolit.com/wiki/index.php/Plugin48

https://wiki.wemos.cc/products:d1_mini_ ... hield#pins

When I send HTTP request, I see the command in log, but motor does not turn.

http://192.168.178.66/control?cmd=Motor ... ckward,200

Any advice would be appreciated.

thx

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#12 Post by TungstenE2 » 24 May 2018, 09:22

There is a fix for the motorshield firmware.
Now the I2C scanner finds the 0x30 device.

https://hackaday.io/project/18439-motor ... rogramming

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#13 Post by TungstenE2 » 27 May 2018, 20:00

good news. wemos motorshield plugin is under development. stay tuned...

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#14 Post by TungstenE2 » 10 Jun 2018, 19:50

added new Plugin for Wemos Motorshield P_078 in Testing

https://github.com/letscontrolit/ESPEasy/pull/1492

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#15 Post by TungstenE2 » 29 Aug 2018, 15:13

Wemos Motor Shield Plugin is now in official mega release!

See wiki:
https://www.letscontrolit.com/wiki/inde ... otorshield

User avatar
grovkillen
Core team member
Posts: 3138
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Esp Easy and Wemos Motor Shield

#16 Post by grovkillen » 29 Aug 2018, 15:42

Please move the rules example to the rules tutorial page :)
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

aussieatlarge
Normal user
Posts: 7
Joined: 25 Aug 2017, 03:35

Re: Esp Easy and Wemos Motor Shield

#17 Post by aussieatlarge » 31 Oct 2018, 12:51

I can confirm that the "new" boards (or might be boards purchased from Wemos Aliexpress store) work without flash.
Well kinda. They work just fine with example Arduino sketches.
However, I cannot get them to work with ESPEASY.
WemosMotorShieldCMD, 0, Forward, 30 does nothing. Not even cause the command script to popup like it does whith gpio, 14, 1
Am I missing something?

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#18 Post by TungstenE2 » 31 Oct 2018, 13:39

did you flash ESPeasy testing version? Only in testing version the plugin is included.

just follow the wiki.

https://www.letscontrolit.com/wiki/inde ... otorshield

aussieatlarge
Normal user
Posts: 7
Joined: 25 Aug 2017, 03:35

Re: Esp Easy and Wemos Motor Shield

#19 Post by aussieatlarge » 31 Oct 2018, 14:12

Tungsten
I followed the wiki.
I even flashed an old driver board - the difference between the "new" board and the flashed board is that the new board shows in an I2C search.
When I send the command http://192.168.1.178/control?cmd=WemosM ... Forward,99
i see this in the log WemosMotor: Motor = 1 Direction = forward Speed = 99
motor is connected to B1 B2
power is connected to motorboard.
board works perfectly with example Arduino code.

the only strange thing is that when I create the device I get the error at the top of the screen
Invalid character in names. Do not use ',#[]' or space

Please help. I know I am close. version mega-20181031 dev

TungstenE2
Normal user
Posts: 77
Joined: 03 Apr 2018, 21:46

Re: Esp Easy and Wemos Motor Shield

#20 Post by TungstenE2 » 31 Oct 2018, 14:46

can you post error message?

I am using ESP_Easy_mega-20180927_test_ESP8266_4096.bin

And I use A1, A2:
WemosMotorShieldCMD 0 Forward 30

Device Name: WemosDCMotor

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests