Page 1 of 1

Very simple Temperature rule from Wiki not working?

Posted: 28 Dec 2018, 10:19
by EDsteve
Hi,
i just tried to make some sort of thermostat. These are my devices:
ter.JPG
ter.JPG (62.68 KiB) Viewed 2078 times
And this is my rule same as you can find in the wiki:

Code: Select all

on [tempsolar]#Temperature>20 do
   GPIO,13,1
endon
Wiki:
ex.JPG
ex.JPG (15.72 KiB) Viewed 2078 times
But even the temp is over 20. The Value of the GPIO13 always stays at 0.

I am not a friend o the rules because i m no coder.. but how can i even mess up the most simple thing?

Re: Very simple Temperature rule from Wiki not working?

Posted: 28 Dec 2018, 10:24
by dynamicdave
Your question is very similar to the one I answered last night.
Have a look at this link...

http://www.letscontrolit.com/forum/view ... f=6&t=6228

Cheers from David

Re: Very simple Temperature rule from Wiki not working?

Posted: 28 Dec 2018, 10:40
by iron
Shouldn't it be :

On tempsolar#Temperature>20 do

instead of :

On [tempsolar]#Temperature>20 do

?

-D

Re: Very simple Temperature rule from Wiki not working?

Posted: 28 Dec 2018, 10:53
by EDsteve
iron wrote: 28 Dec 2018, 10:40 Shouldn't it be :

On tempsolar#Temperature>20 do

instead of :

On [tempsolar]#Temperature>20 do

?

-D
Indeed... It's always the small thing things. Thanks. Works now.
Maybe it's time to update the wiki. Two people struggled with it within two days.

dynamicdave wrote: 28 Dec 2018, 10:24 Your question is very similar to the one I answered last night.
Have a look at this link...

http://www.letscontrolit.com/forum/view ... f=6&t=6228

Cheers from David
Thanks for the link. Yes. That works too. Also good to have the timers if needed.

Re: Very simple Temperature rule from Wiki not working?

Posted: 28 Dec 2018, 11:31
by grovkillen
EDsteve wrote: 28 Dec 2018, 10:53
iron wrote: 28 Dec 2018, 10:40 Shouldn't it be :

On tempsolar#Temperature>20 do

instead of :

On [tempsolar]#Temperature>20 do

?

-D
Indeed... It's always the small thing things. Thanks. Works now.
Maybe it's time to update the wiki. Two people struggled with it within two days.

dynamicdave wrote: 28 Dec 2018, 10:24 Your question is very similar to the one I answered last night.
Have a look at this link...

http://www.letscontrolit.com/forum/view ... f=6&t=6228

Cheers from David
Thanks for the link. Yes. That works too. Also good to have the timers if needed.
I'm moving the wiki to read the docs. We are abandoning the wiki in order to have a good versioning of the docs.

https://espeasy.readthedocs.io/en/lates ... Rules.html