SYSLOG priority in sleep/wake

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
skittlez
Normal user
Posts: 11
Joined: 30 Apr 2019, 03:42

SYSLOG priority in sleep/wake

#1 Post by skittlez » 29 May 2019, 12:22

Hi,
I am using a regular 4M nodemcu with the 25/4 mega release.

I have a problem with Syslog.

If I use my device in normal mode (no deep sleep), the syslog server collects data that mirrors the serial log (apart from the stuff before Wifi connects obviously). It's pretty much sent simultaneously

If I use it in the wake time following deep sleep, it either only sends stuff to the syslog server occasionally or not at all.
Any ideas why?

I have tried multiple settings of my device time between reads (a BME280) and different times for the wake time and deep sleep time.
Any suggestions of what has worked for other people?

Thanks very much

skittlez
Normal user
Posts: 11
Joined: 30 Apr 2019, 03:42

Re: SYSLOG priority in sleep/wake

#2 Post by skittlez » 04 Jun 2019, 01:45

Hi, my previous post has been up for a while with no comments...
Can anyone point me to a simple tutorial that details the steps to
* set up an esp8266 that goes into deep sleep for 5 minutes at a time
* when it wakes up, it reads from a sensor (e.g. a BME280) and sends this to a syslog server once and then shuts down.

That's all I really want to do, I just need to be able to do it realiably which it isn't at the moment

If syslog is problematic, please let me know!!!

Any help hugely appreciated, I can imagine that this is something that a lot of other people probably want to do too.

User avatar
ThomasB
Normal user
Posts: 328
Joined: 17 Jun 2018, 20:41
Location: USA

Re: SYSLOG priority in sleep/wake

#3 Post by ThomasB » 04 Jun 2019, 19:17

If I use it in the wake time following deep sleep, it either only sends stuff to the syslog server occasionally or not at all. Any ideas why?
Without rules to force an update, device data needs an event (interval or data change) before it is sent to syslog.

Try this: Enable rules (Tools-AdvancedSettings->RulesSettings). Even with a blank rule file, this trick may help syslog send more messages. If not, then create some rules that perform an action on the data you want to log. I also suggest that you increase the wake time to ensure that syslog has time to fully flush.
If syslog is problematic, please let me know!!!
I suspect that your special ESPEasy application (deep sleep / syslog) is unique and that the user fan base can be counted on one finger (you). So I think you are in the best position to answer that question.

Using syslog is not considered a highly robust method of sending important data (it's blind one way communication). The normal solution is to send data by MQTT using rules, which I highly recommend.

- Thomas

skittlez
Normal user
Posts: 11
Joined: 30 Apr 2019, 03:42

Re: SYSLOG priority in sleep/wake

#4 Post by skittlez » 05 Jun 2019, 05:58

Thank you for your help Thomas, I have Rules enabled and I am still experiencing difficulties.

I take your point about Syslog and will use MQTT via Rules and extend the on-time.

Cheers

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests