Page 1 of 1

Wemos D1 reboots every minute

Posted: 14 Jun 2020, 08:31
by Dondolo
Hi, my Wemos D1 reboots every minute.
The ESP8266 is on a breadboard without external sensors and the power supply comes from a regulated power supply with 5V.

If I re-install espeasy it is okay.

I send values to the ESP via sendtohttp and process them with the rules (old rules).

Can the regular reboot be due to the interaction between rules and sendtohttp?

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 09:50
by mrwee
What if you remove sendtohhtp? Does the rebooting stop?

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 10:38
by Dondolo
mrwee wrote:
14 Jun 2020, 09:50
What if you remove sendtohhtp? Does the rebooting stop?
Yes, exactly thanks. I have changed the IP address and the ESP is running stable.
What's going wrong

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 11:23
by TD-er
Maybe a conflict where multiple devices use the same IP?
Can you try ping the old IP to make sure?

If the device does not receive a reply in due time, it might sometimes crash.. sadly.
But also, if it got replies meant for other nodes the buffers may fill up as they are not handled in due time.

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 12:48
by Dondolo
TD-er wrote:
14 Jun 2020, 11:23
Maybe a conflict where multiple devices use the same IP?
Can you try ping the old IP to make sure?

If the device does not receive a reply in due time, it might sometimes crash.. sadly.
But also, if it got replies meant for other nodes the buffers may fill up as they are not handled in due time.
Hi Td-er, thanks for the feedback.
The ping runs into the empty no same IP. Without Sendtohttp, the ESP has been running stable for hours.

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 13:36
by Dondolo
Dondolo wrote:
14 Jun 2020, 12:48
TD-er wrote:
14 Jun 2020, 11:23
Maybe a conflict where multiple devices use the same IP?
Can you try ping the old IP to make sure?

If the device does not receive a reply in due time, it might sometimes crash.. sadly.
But also, if it got replies meant for other nodes the buffers may fill up as they are not handled in due time.
Hi Td-er, thanks for the feedback.
The ping runs into the empty no same IP. Without Sendtohttp, the ESP has been running stable for hours.
Interesting, I used the sendtohttp command with the new IP address. No reboot, no problem ESP runs stable

Re: Wemos D1 reboots every minute

Posted: 14 Jun 2020, 20:10
by Ath
You say you changed the ip-address, does that mean you sent data to a non-existing ip with the sendtohttp command? If so, it could explain the reboots, as sendtohttp waits for an ack from the destination, but as that doesn't respond, the watchdog timer forces a reboot as the unit is not responding during the wait.