RFLink R42, strange Debug output breaks parser

Information and news about RFLink development and releases

Moderators: rtenklooster, BertB, Voyager, Stuntteam

Post Reply
Message
Author
NemoN
Normal user
Posts: 5
Joined: 09 Jul 2016, 22:19

RFLink R42, strange Debug output breaks parser

#1 Post by NemoN » 14 Jul 2016, 22:33

Hello,

i using the R42 firmware and getting some strange "Debug" outputs that are breaking the protocol parser:
Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Jan 1 2014, 17:13:19.
Port /dev/ttyACM0, 22:27:20

Press CTRL-A Z for help on special keys

0;Alecto V4;ID=5f58;TEMP=008e;HUM=83;
20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R42;
20;01;GlobalTronics;ID=0032;TEMP=0089;BAT=LOW;
Debug aaaa55000f9a00
20;02;RTS;ID=0f959a;SWITCH=01;CMD=ON;
20;03;Polling DBG;5be013510e;
20;04;Auriol V2;ID=3F01;TEMP=008a;BAT=LOW;
20;05;Alecto V4;ID=5f58;TEMP=008d;HUM=83;
20;06;UPM_Esic;ID=0003;TEMP=008f;HUM=00;BAT=OK;
Debug aaaad500000b01
20;07;OregonV1;ID=0083;TEMP=00a4;BAT=OK;
20;08;Polling DBG;5be013510e;
20;09;Polling DBG;5be013510e;
20;0A;Polling DBG;5be013510e;
20;0B;Polling DBG;5be013510e;
20;0C;GlobalTronics;ID=0032;TEMP=0089;BAT=LOW;
20;0D;Alecto V4;ID=5f58;TEMP=008d;HUM=83;
Any ideas?

Bests
NemoN

User avatar
Stuntteam
Site Beheer
Posts: 614
Joined: 27 Jan 2016, 16:46

Re: RFLink R42, strange Debug output breaks parser

#2 Post by Stuntteam » 15 Jul 2016, 00:42

Yeah.. Thanks for reporting.
It is already fixed.
See the changelog for the upcoming R43
http://www.nemcon.nl/blog2/changelog
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

NemoN
Normal user
Posts: 5
Joined: 09 Jul 2016, 22:19

Re: RFLink R42, strange Debug output breaks parser

#3 Post by NemoN » 15 Jul 2016, 19:11

It is possible to test the Beta R43?

User avatar
Stuntteam
Site Beheer
Posts: 614
Joined: 27 Jan 2016, 16:46

Re: RFLink R42, strange Debug output breaks parser

#4 Post by Stuntteam » 15 Jul 2016, 20:53

send a mail to frankzirrone@gmail.com
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

NemoN
Normal user
Posts: 5
Joined: 09 Jul 2016, 22:19

Re: RFLink R42, strange Debug output breaks parser

#5 Post by NemoN » 27 Jul 2016, 15:46

thanks, R43Beta fixed this issue!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest