Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
tparvais
Normal user
Posts: 79
Joined: 28 Oct 2015, 23:13

Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#1 Post by tparvais » 21 May 2020, 20:31

Hello

I have a lot of issues to load firmware to wemos D1 mini pro 16M.

I have such module. It was working fine with an old FW. (don't know which one)

I removed the SMD resistor 0 ohm from the pcb to switch from on board ceramic antenna to use external antenna (I simply shunt the external connector)
The module didn't boot anymore :-(

I tried to flash with last FW=> NOK
I tried to gflash 16MB blank file ==> NOK
I use eSP official flash tool with 16MB fblank file then upload again ==> NOK


INIT : Booting version: (ESP82xx Core 9c56ed1f, NONOS SDK 2.2.2-dev(38a443e), LWIP: 2.1.2 PUYA support)
85 : Info : INIT : Free RAM:33376
86 : Inf


Any idea to recover ?

Thank you

User avatar
ThomasB
Normal user
Posts: 740
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#2 Post by ThomasB » 21 May 2020, 21:23

I have a lot of issues to load firmware to wemos D1 mini pro 16M. {snip} It was working fine with an old FW. (don't know which one)
If it was working on an older version then I highly doubt it was a 16M build (would likely have been 1M or 4M). I suggest you try ESP_Easy_mega-20200426_normal_ESP8266_4M1M.bin from the April 26 release. Be sure to clear out the flash by loading blank_16MB.bin first.
I removed the SMD resistor 0 ohm from the pcb to switch from on board ceramic antenna to use external antenna (I simply shunt the external connector)
The module didn't boot anymore
The board may have been damaged during the rework. Do another visual inspection with a magnifying lens on both sides of the board. With a bit of luck you might spot a problem.
I tried to flash with last FW=> NOK
I tried to gflash 16MB blank file ==> NOK
I use eSP official flash tool with 16MB fblank file then upload again ==> NOK
It's not clear if you mean the upload fails, or if upload is OK but the board does not boot. Please confirm which is occurring.
BTW, if you can successfully flash the board then upload a simple LED blink sketch to confirm the board can boot.

- Thomas

tparvais
Normal user
Posts: 79
Joined: 28 Oct 2015, 23:13

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#3 Post by tparvais » 21 May 2020, 21:48

Thanks thomas

The esp does not boot properly

I’ll try with 4MB but as far as I know. I always upload the firmware at the size of the flash

4 or 16 MB

User avatar
ThomasB
Normal user
Posts: 740
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#4 Post by ThomasB » 21 May 2020, 22:45

If the Apr-26-2020 release works then perhaps your problem is related to a reported issue that affects the May-16 build:
https://github.com/letscontrolit/ESPEasy/issues/3078

- Thomas

tparvais
Normal user
Posts: 79
Joined: 28 Oct 2015, 23:13

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#5 Post by tparvais » 22 May 2020, 11:18

strangely, with 4MB april it works on this 16MB board

thanks

TD-er
Core team member
Posts: 3404
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#6 Post by TD-er » 22 May 2020, 12:58

tparvais wrote: 22 May 2020, 11:18 strangely, with 4MB april it works on this 16MB board

thanks
Well it always works with a build made for smaller flash sizes.
For 16M units I always use a 4M build, as SPIFFS (the file system) is terribly slow on large file system sizes.
It is unusable on a 14MB file system.
So I advice to stick to 4M builds.
You may want to use the 4M2M builds, as it will give you 2 MB of filesystem space instead of the default 1MB.

In the sysinfo page you can see how large the flash is, just for verification.

tparvais
Normal user
Posts: 79
Joined: 28 Oct 2015, 23:13

Re: Problem to upload ESP_Easy_mega_20200516_normal_ESP8266_16M.bin

#7 Post by tparvais » 22 May 2020, 15:48

Thanks for your this important clarification !

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests