Rflinkloader fault

About receivers, transmitters, transceivers, connections, antennas etc.

Moderators: rtenklooster, Voyager, BertB, Stuntteam

Post Reply
Message
Author
derksuh
Normal user
Posts: 2
Joined: 25 Feb 2019, 17:46

Rflinkloader fault

#1 Post by derksuh » 25 Feb 2019, 20:27

Hello all,

I’m trying to install the latest version of rflink on my arduino mega, but it won’t program it. When i download a sketch with arduino ide it works fine. With rf link loader i see the following debug.

Serial port test:
Serial port ok
Serial port test done
param: -p atmega2560 -c stk500v2 -P \\.\COM3 -b 115200 -U flash:w: C... location of file on computer.

---------------------------------------
Execute external program:
Exitcode 1
External program ended with an error
Execute external program done
Programming arduino failed
Programming arduino done

User avatar
Stuntteam
Site Beheer
Posts: 727
Joined: 27 Jan 2016, 16:46

Re: Rflinkloader fault

#2 Post by Stuntteam » 26 Feb 2019, 00:13

are you sure all files from the archive are copied?
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

derksuh
Normal user
Posts: 2
Joined: 25 Feb 2019, 17:46

Re: Rflinkloader fault

#3 Post by derksuh » 26 Feb 2019, 21:18

Unpacked the folder again, and now it is working.
Didn’t think about doing that before.

PeJeWe
Normal user
Posts: 5
Joined: 22 Mar 2022, 18:52

Re: Rflinkloader fault

#4 Post by PeJeWe » 09 Jan 2023, 21:29

Bij het (her)programmeren van mijn bordje krijg ik de volgende melding:

Code: Select all

Debug mode activated
------------------------------
Programming Arduino:
Port COM4
Filename G:\Downloads\RFLink_v1.1_r48\RFLink.cpp.hex
------------------------------
Serial port test:
Serial port ok
Serial port test done
param: -p atmega2560 -c stk500v2 -P \\.\COM4 -b 115200 -U flash:w:"G:\Downloads\RFLink_v1.1_r48\RFLink.cpp.hex":i
------------------------------
Execute external program:
Exitcode 1
External program ended with an error
Execute external program done
Heb alle bestanden uitgepakt in 1 map.
Het wordt door windows 10 als "Arduino Mega 2560 (COM4) herkend.
Ook de loader als "uitvoeren met admin rechten geprobeerd.

nog ideen?

update:
Image

is de melding die ook nog krijg

PeJeWe
Normal user
Posts: 5
Joined: 22 Mar 2022, 18:52

Re: Rflinkloader fault

#5 Post by PeJeWe » 11 Jan 2023, 19:52

I have managed to get it working again by uninstalling the Arduino Mega 2560 windows driver in the windows device manager.
Reinstalled the arduino board.
Restart the RFLink loader and upload/install the RFLink.cpp.hex file.
After that it was up and running again.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 0 guests