Relays activate at startup

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
RaphV57
New user
Posts: 2
Joined: 26 May 2023, 23:08

Relays activate at startup

#1 Post by RaphV57 » 26 May 2023, 23:18

Hello,

I'm controlling a fan speed with double relay board and capacitors. When the wemos boot, the two relay are briefly activated. Have a look at my video to better understand.

Is there a way to avoid it?

Schematic

TD-er
Core team member
Posts: 8986
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Relays activate at startup

#2 Post by TD-er » 26 May 2023, 23:27

See "GPIO Behavior Summary" on this page: https://rabbithole.wwwdotorg.org/2017/0 ... -gpio.html
And the table on this page: https://lastminuteengineers.com/esp8266 ... reference/

Of course this page should be your first reference when picking pins to use :)
https://espeasy.readthedocs.io/en/lates ... on-esp8266

The only ones which are safe to use are GPIO 5 & 4 (D1/D2)
Second best are GPIO 14/12/13 (D5/D6/D7)

RaphV57
New user
Posts: 2
Joined: 26 May 2023, 23:08

Re: Relays activate at startup

#3 Post by RaphV57 » 27 May 2023, 07:22

Thank you!
I got tricked once again with this GPIO selection... :oops:

TD-er
Core team member
Posts: 8986
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Relays activate at startup

#4 Post by TD-er » 27 May 2023, 13:17

RaphV57 wrote: 27 May 2023, 07:22 Thank you!
I got tricked once again with this GPIO selection... :oops:
Happens to me all the time, that's why I created that table in the docs :)

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests