Adafruit Motorshield v2 with Stepper Motor

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
fbrors
Normal user
Posts: 3
Joined: 14 Apr 2018, 22:57

Adafruit Motorshield v2 with Stepper Motor

#1 Post by fbrors » 26 Mar 2019, 00:29

dear friends,

I tried to give the modified http-command

http://<ESP IP address>/control?cmd=MotorShieldCMD,Stepper,<Motornumber>,<Forward/Backward/Release>,<Steps>,<SINGLE/DOUBLE/INTERLEAVE/MICROSTEP>

But nothing happens with the motor:(

But the Log says

"139347: HTTP: MotorShieldCMD,Stepper,1,Forward,150,SINGLE
139381: Stepper1->Forward Steps: 150 SINGLE

I use the chinese "Adafruit_Motor_Shield_v2" with chinese Wemos D1 R2 (Arduino Uno size)
&
ESP_Easy_mega-20190315_test_core_260_sdk3_alpha_ESP8266_4M.bin

i already
- checked motor and wires with arduino
- mod the Motorshild to 3v


Any Idea?

User avatar
ThomasB
Normal user
Posts: 330
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Adafruit Motorshield v2 with Stepper Motor

#2 Post by ThomasB » 01 Apr 2019, 03:08

Within the last month you're the second person to report problems getting that board configuration to work with ESPEasy. And it doesn't appear that the problem was solved because the open topic has not been updated. So this motor shield board might not be the best choice until someone shares detailed instructions on how to make it work with ESPEasy.

Here's the previous discussion:
viewtopic.php?f=5&t=6526

EDIT: There have been some software maintenance changes made to the plugin over the last few months (Mar 2018, Jan 2019, etc). There is a chance that the plugin wasn't fully validated (tested with real hardware) after being updated. It may be necessary to try a release from before Feb 2018, but start with a Dec 2018 release first.

- Thomas

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest