Pulse Counter - jumping values

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Amari
Normal user
Posts: 4
Joined: 17 May 2019, 10:53

Pulse Counter - jumping values

#1 Post by Amari » 17 May 2019, 11:20

Hi,
I've got a question about the implementation of the pulse counter.

I wanted to use it to read in an analog energy meter with ferraris disc.
My sensor is working fine and the total count value seems to be correct.

The part which seems off is the time. The disc takes at least 10 sec or more to turn arround once. But sometimes I get readings with 400 ms, which is just not possible.
I've set the delay to 60 and also tried 600 seconds. Is the time set to 0 when the data is pushed to the controller? Debounce should be fine too, I also have led's on the sensor to show the state, and that part seems reliable.

My understanding was, that time displays the time in ms between the last count? Is that right? Or is it between the last two counts? There has to be some error, and the reading is sent when it doesn't display a full circle.

Screenshot showing time differences with a 3 minute period (delay 300 in esp)
Screen Shot 2019-05-17 at 11.06.57.png
Screen Shot 2019-05-17 at 11.06.57.png (151.26 KiB) Viewed 269 times



ESP Info:
Screen Shot 2019-05-17 at 11.13.14.png
Screen Shot 2019-05-17 at 11.13.14.png (110.27 KiB) Viewed 269 times
Screen Shot 2019-05-17 at 11.12.22.png
Screen Shot 2019-05-17 at 11.12.22.png (129.48 KiB) Viewed 269 times

Amari
Normal user
Posts: 4
Joined: 17 May 2019, 10:53

Re: Pulse Counter - jumping values

#2 Post by Amari » 17 May 2019, 11:22

Another question??

Sometimes the web interface does not respond. As it seems offline or disconnected (ping not working too).
BUT, (I use the FHEM HTTP controller), fhem shows me the device is present and I get readings. WiFi signal is good to. I installed an access point in the next room.

User avatar
grovkillen
Core team member
Posts: 3140
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Pulse Counter - jumping values

#3 Post by grovkillen » 17 May 2019, 12:34

Yep, sometimes the unit is busy doing stuff and doesn't "hear" the request. This is something we're improving continuously but if you have a lot of devices rolling on the unit it will be more likely to miss these request. If this is the case you might want to rethink how the unit is built and perhaps disable some devices prior to accessing the unit over the web interface.
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

Amari
Normal user
Posts: 4
Joined: 17 May 2019, 10:53

Re: Pulse Counter - jumping values

#4 Post by Amari » 17 May 2019, 13:09

Ah, ok. This will explain that behavior. Regards the devices, I had this problem even with no devices configured. Network access is only via fhem. And sometimes http GUI when I want to look something up.

Amari
Normal user
Posts: 4
Joined: 17 May 2019, 10:53

Re: Pulse Counter - jumping values

#5 Post by Amari » 20 May 2019, 13:28

anyone?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests