config.dat - is it forward compatible?

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
dampa
Normal user
Posts: 38
Joined: 19 Jul 2018, 01:48

config.dat - is it forward compatible?

#1 Post by dampa » 12 Aug 2019, 12:02

If I backup a device's config.dat and then upgrade espeasy, will the config.dat import without issues or is it release dependent?

For example - say a device is using mega-20190305 and I backup the config.dat.

Code: Select all

deviceX (mega-20190305) -> config.dat(mega-20190305)
Next I upgrade to mega-20190809.

Code: Select all

mega-20190809->deviceX
Will importing the config.dat work properly or is there the chance something will have changed so the config.dat will not import

Code: Select all

config.dat(mega-20190305) -> deviceX(mega-20190809) 
How about the rest of the '.dat' files?

TD-er
Core team member
Posts: 1360
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: config.dat - is it forward compatible?

#2 Post by TD-er » 12 Aug 2019, 14:41

It should be forward upgrade compatible.
A few times, when an issue was reported that appeared hard to reproduce, it helped to delete that part of the settings and add it again.
For example the sysinfo plugin has been known to give some strange issues.
Remove and add again did seem to solve the issues.

One thing that for sure is broken right now, is when you're using a plugin which uses "remote feed".
In older builds this was called "global share".
This is now done via the ESPeasy p2p controller.
If you use that, you may need to add this particular controller.
For more info on that one, see the documentation: https://espeasy.readthedocs.io/en/lates ... hlight=p2p

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests