Unreliable SendToHTTP?

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Vilda
Normal user
Posts: 8
Joined: 16 Jun 2019, 22:12

Unreliable SendToHTTP?

#1 Post by Vilda » 22 Aug 2019, 21:42

I am trying to use SendToHTTP each minute (rules code fragment below) to send actual data to my server and basically it works. The problem is there are significant gaps in the data received (see the attached picture or directly at http://itrubec.cz/monitor/iotbeehive-ibm-roof-en.php). Time to time are data missing for some minutes and then they appear again. What could be causing this?
What more - SendToHTTP to ThingSpeak stopped to work with the last update. Is someome experiencing similar behaviour? Is it caused by the latest release or is something screwed up with my rules/setup?
I am using ESP_Easy_mega-20190817_dev_ESP8266_4M.bin

Code: Select all

On Rules#Timer=2 do
  timerSet,2,59
  if [Relay#R]=0
    SendToHTTP itrubec.cz,80,/monitor/xxx.php?a=[DHT#TIN]&b=[DHT#HIN]&c=[BME#TOUT]&d=[BME#HOUT]&e=[BME#POUT]&f=[Light#L]&g=0&h=[HP1#hp1]&i=[HP2#hp2]&j=[Sonda#sonda]&key=xxx&dev=xxx
  else
    SendToHTTP itrubec.cz,80,/monitor/xxx.php?a=[DHT#TIN]&b=[DHT#HIN]&c=[BME#TOUT]&d=[BME#HOUT]&e=[BME#POUT]&f=[Light#L]&g=1&h=[HP1#hp1]&i=[HP2#hp2]&j=[Sonda#sonda]&key=xxx&dev=xxx
  endif
endon
Attachments
2019-08-22 monitoring gaps.png
2019-08-22 monitoring gaps.png (12.3 KiB) Viewed 1062 times

User avatar
grovkillen
Core team member
Posts: 3221
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Unreliable SendToHTTP?

#2 Post by grovkillen » 23 Aug 2019, 05:41

Not sure, perhaps the setting of the timer after the if statement could help?
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

TD-er
Core team member
Posts: 1487
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Unreliable SendToHTTP?

#3 Post by TD-er » 23 Aug 2019, 13:06

SendToHTTP does not wait for an acknowledgement.
The controllers can be set to wait for an acknowledgement.

Something similar was found last week regarding sending data to ThingSpeak via HTTP.
See: https://github.com/letscontrolit/ESPEas ... -522628901

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 16 guests