[SOLVED] Error building V2.0 with PlatformIO

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
Flying Domotic
Normal user
Posts: 4
Joined: 27 Aug 2019, 23:57

[SOLVED] Error building V2.0 with PlatformIO

#1 Post by Flying Domotic » 08 Oct 2019, 23:11

Hello,

First of all, I do apologies in advance if this question is a dummy one, but I'm a newby at ESPEasy, and even after trying to find a solution on Internet, I'm not able to fix the issue myself.

I'm trying to compile ESPEasy V2.0 branch with PlatformIO (Atom version, not VSCode).
Target is ESP8266, 4MB, normal version.
ESPEasy.ino was selected.
No changes to the original GitHub 2.0 version.
ESPEasy-Globals.h contains a "#define PLUGIN_BUILD_NORMAL", other #define PLUGIN_BUILD_xxx are commented out.

Error when linking is:
Linking .pio\build\normal_ESP8266_4096\firmware.elf
c:/users/xxx/documents/home/.platformio/packages/toolchain-xtensa@1.40802.0/bin/../lib/gcc/xtensa-lx106-elf/4.8.2/../../../../xtensa-lx106-elf/bin/ld.exe: .pio\build\normal_ESP8266_4096\firmware.elf section `.text' will not fit in region `iram1_0_seg'
collect2.exe: error: ld returned 1 exit status
*** [.pio\build\normal_ESP8266_4096\firmware.elf] Error 1
Search on Internet seems to indicate that static text is too large for memory size, and some technics like moving text to flash has to be used (a very common thing for Arduino). As this is the "normal" version (normally the smallest one), without any changes, I guess I'm doing something wrong, very probably with a tricky solution.

Thanks in advance for your help,
Last edited by Flying Domotic on 19 Oct 2019, 18:55, edited 1 time in total.

TD-er
Core team member
Posts: 1656
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Error building V2.0 with PlatformIO

#2 Post by TD-er » 09 Oct 2019, 13:11

What exact branch do you use?
You stated "2.0 branch", but that one has been "abandoned" a long time ago.
If you did not specifically select a branch, then you should be on the "mega" branch.

It looks like you're building normal_ESP8266_4096, but that's an old name schema, which makes me think you did actually checkout an old branch.
So please checkout mega branch and try again.

Did you make any changes?
Using just the version as now present on Github, then it should build using core 2.5.2, so you should be able to build a version.

Flying Domotic
Normal user
Posts: 4
Joined: 27 Aug 2019, 23:57

Re: Error building V2.0 with PlatformIO

#3 Post by Flying Domotic » 11 Oct 2019, 10:57

I just did download V2.0 branch from GitHib, w/o any changes.

I'll try Mega branch. Thx!

May I suggest to clarify a bit Wiki on the release schema, and recommended branch(es)? Reading it, I concluded that stable version was 2.0, and Mega was a dev one ;-) It may perhaps be useful to give a direct pointer to last stable version.

Flying Domotic
Normal user
Posts: 4
Joined: 27 Aug 2019, 23:57

Re: Error building V2.0 with PlatformIO

#4 Post by Flying Domotic » 19 Oct 2019, 18:53

Effectively, with Mega branch, this is working better! Thx !

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests