Only devices no data transfer with P2P Networking

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
monimi
Normal user
Posts: 3
Joined: 01 Nov 2019, 00:57

Only devices no data transfer with P2P Networking

#1 Post by monimi » 04 Nov 2019, 17:14

Hello,
I use 2 Nodemcu device-0 and device-1. Both have the same firmware mega-20191103.
I have connected at device-0 two sensors:
BMP280 Temp/Humidity/Pressure.
DHT22 Temp/Humidity.
I want, that unit-0 read the data and send to unit-1 via p2p.
Unit-0 reads the data correctly, but no data arrives unit-1. Only the devices in the columns were registered when I activated p2p.
To view, here a screenshot. There are the devices as not enabled to see. But even if I turn it on, nothing changes.
I also made a test with an older version mega-20190508. This works fine.
Does anyone have a suggestion to fix the problem?

https://www.bilder-upload.eu/bild-2aade ... 8.png.html
Image

TD-er
Core team member
Posts: 1776
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Only devices no data transfer with P2P Networking

#2 Post by TD-er » 04 Nov 2019, 19:15

You must have a unit number set (so not 0 and not 255)
On the 'receiving' plugin, what unit ID is shown there?

See also this for some guidelines and common issues: https://espeasy.readthedocs.io/en/lates ... mong-nodes

monimi
Normal user
Posts: 3
Joined: 01 Nov 2019, 00:57

Re: Only devices no data transfer with P2P Networking

#3 Post by monimi » 04 Nov 2019, 20:23

Thanks for your help.
I did not know that unit number 0 should not be used.
I have now changed to unit 1 and unit 2 and it works fine.
Now you can see in the column (port) Unit 1 - ESP_Easy and the right values.
Thank you again.

Image[https://www.bilder-upload.eu/bild-91d74 ... 9.png.html]

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests