mqtt commands doesn't work

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
dredrash
Normal user
Posts: 5
Joined: 27 Jan 2020, 19:29

mqtt commands doesn't work

#1 Post by dredrash » 27 Jan 2020, 20:58

Hello, i use mega-20191208 stable for esp8266, and commands through mqtt are not acknowledged by espeasy. My setup is domoticz, mosquito espeasy, so espeasy is subscribed to domoticz/out. I have an device Output - Domoticz MQTT Helper which is working fine when there is change in this domoticz switch , but when i try to post comands like domoticz/out msg: "GPIO,12,1" or domoticz/out/cmd msg: "GPIO,12,1" there is no reaction.
i tried almost all combination and suggestions like
domoticz/out msg: "GPIO,12,1"
domoticz/out/cmd msg: "GPIO,12,1"
domoticz/out/cmd/GPIO/12 msg: "1"
domoticz/out/GPIO/12 msg: "1"

As well i tried to subscribe to domoticz/out/# but still nothing.

wim16
Normal user
Posts: 79
Joined: 01 May 2017, 20:35

Re: mqtt commands doesn't work

#2 Post by wim16 » 28 Jan 2020, 08:57

You can not send a command this way; the Domoticz MQTT Helper accepts only messages in the format of Domoticz.
Also keep in mind that if you send a command not from Domoticz, the status of the switch in Domoticz will not change and will be wrong.

Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests