Arduino ESP8266 Compile OK, but lose ESP afer reboot!

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
ohaldi
Normal user
Posts: 5
Joined: 31 Jan 2020, 09:10

Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#1 Post by ohaldi » 31 Jan 2020, 09:30

Good morning, sir,
I can easily compile and upload ESPEasy Mega.
I changed in the custom.h file the data to access my router. But I still have to reconfigure it with the address : 192.168.4.1

#define DEFAULT_NAME "MyEspEasyDevice" // Enter your device friendly name
#define UNIT 0 // Unit Number
#define DEFAULT_DELAY 60 // Sleep Delay in seconds

// --- Wifi AP Mode (when your Wifi Network is not reachable) ----------------------------------------
#define DEFAULT_AP_IP 192, 168, 90, 90 // Enter IP address (comma separated) for AP (config) mode
#define DEFAULT_AP_SUBNET 255, 255, 255, 0 // Enter IP address (comma separated) for AP (config) mode
#define DEFAULT_AP_KEY "configesp" // Enter network WPA key for AP (config) mode

// --- Wifi Client Mode -----------------------------------------------------------------------------
#define DEFAULT_SSID "ATEHO" // Enter your network SSID
#define DEFAULT_KEY "stark2015" // Enter your network WPA key
#define DEFAULT_USE_STATIC_IP true // (true|false) enabled or disabled static IP
#define DEFAULT_IP "192.168.90.80" // Enter your IP address
#define DEFAULT_DNS "192.168.90.1" // Enter your DNS
#define DEFAULT_GW "192.168.90.1" // Enter your Gateway
#define DEFAULT_SUBNET "255.255.255.0" // Enter your Subnet
#define DEFAULT_IPRANGE_LOW "0.0.0.0" // Allowed IP range to access webserver
#define DEFAULT_IPRANGE_HIGH "255.255.255.255" // Allowed IP range to access webserver
#define DEFAULT_IP_BLOCK_LEVEL 1 // 0: ALL_ALLOWED 1: LOCAL_SUBNET_ALLOWED 2:
// ONLY_IP_RANGE_ALLOWED
#define DEFAULT_ADMIN_USERNAME "admin"

If I go through the config menu and I enter my data, a yellow frame displays: Warning: Connected via AP.
If I save the config and reboot my ESP. Then do not lose communication with the ESP8266. Even searching for it in the Wifi or by the fixed IP address that I put.
Many thanks in advance for your help
Otto
Attachments
ArduinoESPEasy-Warning.jpg
ArduinoESPEasy-Warning.jpg (83.13 KiB) Viewed 1190 times
ArduinoESPEasy.jpg
ArduinoESPEasy.jpg (137.27 KiB) Viewed 1190 times

ohaldi
Normal user
Posts: 5
Joined: 31 Jan 2020, 09:10

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#2 Post by ohaldi » 31 Jan 2020, 17:13

I ran more tests. It happens as soon as I set a fixed IP address!
To get my ESP back, I have to re-download the .bin.

User avatar
ThomasB
Normal user
Posts: 539
Joined: 17 Jun 2018, 20:41
Location: USA

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#3 Post by ThomasB » 31 Jan 2020, 17:48

I ran more tests. It happens as soon as I set a fixed IP address!
Static IP is broken in recent releases.
https://github.com/letscontrolit/ESPEasy/issues/2821

- Thomas

hvdwolf
Normal user
Posts: 47
Joined: 09 Jun 2016, 12:37

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#4 Post by hvdwolf » 31 Jan 2020, 18:28

I can confirm this.
Even if I do a straight compile on either Ubuntu bionic or Windows 10 of the git repo, I have the same issue when setting the a fixed ip addres.
U use the latest atom/platformio on both platforms.

ohaldi
Normal user
Posts: 5
Joined: 31 Jan 2020, 09:10

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#5 Post by ohaldi » 02 Feb 2020, 12:42

Many thanks for your information.
If anyone has an idea how to introduce a fixed IP in the source code I'm interested!

TD-er
Core team member
Posts: 2117
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#6 Post by TD-er » 03 Feb 2020, 15:18

ohaldi wrote:
02 Feb 2020, 12:42
Many thanks for your information.
If anyone has an idea how to introduce a fixed IP in the source code I'm interested!
I am working on it, but sadly other (personal) issues have been taking way too much time lately so it has been delayed longer than I would have hoped it would.

stefbo
Normal user
Posts: 18
Joined: 24 Apr 2016, 15:35
Location: Germany

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#7 Post by stefbo » 05 Feb 2020, 22:34

Newest version (mega-20200204) fixed the static ip issue. I tested yesterday and works fine with my devices.
Stefan

ohaldi
Normal user
Posts: 5
Joined: 31 Jan 2020, 09:10

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#8 Post by ohaldi » 06 Feb 2020, 20:55

Thank for your information.
If I download the firmware : ESP_Easy_mega-20200204_custom_ESP8266_4M1M.bin to my ESP8266, every thins work well. I can change the config to a static IP.
I also downloaded the source : ESPEasy-mega-20200204.zip and added the device : _P119_BME680.ino
Compilation is OK. Upload is OK. But same as before as soon I change to a fixed IP the I can't access any more to the ESP!
Strange, isn't it!

hvdwolf
Normal user
Posts: 47
Joined: 09 Jun 2016, 12:37

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#9 Post by hvdwolf » 07 Feb 2020, 13:17

Please add your finding to the issue https://github.com/letscontrolit/ESPEasy/issues/2821

The issue is already closed so you can also open a new one and refer to the 2821 ticket

ohaldi
Normal user
Posts: 5
Joined: 31 Jan 2020, 09:10

Re: Arduino ESP8266 Compile OK, but lose ESP afer reboot!

#10 Post by ohaldi » 11 Feb 2020, 12:50

Thanks for your help.
now, my own compilation work well.

Post Reply

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 27 guests