Display - OLED SSD1306 - no display at all

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
hvdwolf
Normal user
Posts: 47
Joined: 09 Jun 2016, 12:37

Display - OLED SSD1306 - no display at all

#1 Post by hvdwolf » 08 Feb 2020, 17:05

This is really a newbie question in this case. I just purchased an OLED SSD1306 for my thermostat project.
However, I do not get any display.

If I check the wiki OLEDDisplay, it mentions for the connection:

Code: Select all

LCD 	 	ESP-01
 GND 	 	GND
 VCC    	VCC
 SDA		GPIO 0
 SCL		GPIO 2
If I use the plugin inside the 20191208 and the new 20200204 build, even without connecting anything, it shows me.
OLEDSSD1306-plugin.png
OLEDSSD1306-plugin.png (10.53 KiB) Viewed 717 times
And in the Device Config page I have:
SSD1306_DevicePage.png
SSD1306_DevicePage.png (56.18 KiB) Viewed 717 times
No matter what I try or which pins I use like GPIO0/GPIO2 or GPIO4/GPIO5, I get nothing on my display.
From tools I use the "oledcmd,on" and "oldedcmd,off" commands, but also the "oled,1,1,"try out" commands (and variants with variables)
Nothing works. The oled stays black.

I also connected a pushbutton to activate the oled, but still nothing.

Am I doing something stupid?

dampa
Normal user
Posts: 44
Joined: 19 Jul 2018, 01:48

Re: Display - OLED SSD1306 - no display at all

#2 Post by dampa » 08 Feb 2020, 17:18

have you tried using the 'Display - OLED SSD1306' instead of the 'Display - OLED SSD1306/SH1106 Framed' as the device?

hvdwolf
Normal user
Posts: 47
Joined: 09 Jun 2016, 12:37

Re: Display - OLED SSD1306 - no display at all

#3 Post by hvdwolf » 08 Feb 2020, 18:44

Life can be so simple.
It worked immediately.

Thanks a lot.

hvdwolf
Normal user
Posts: 47
Joined: 09 Jun 2016, 12:37

Re: Display - OLED SSD1306 - no display at all

#4 Post by hvdwolf » 08 Feb 2020, 18:48

And now I switched back to "Display - OLED SSD1306/SH1106 Framed" without having pins changed and the like, and it still works.

Great, but why???

dampa
Normal user
Posts: 44
Joined: 19 Jul 2018, 01:48

Re: Display - OLED SSD1306 - no display at all

#5 Post by dampa » 09 Feb 2020, 11:54

As to why, beats me I was just offering an idea to test :D

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests