publish command not working in Rule-Sets

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
User avatar
dynamicdave
Normal user
Posts: 219
Joined: 30 Jan 2017, 20:25
Location: Hampshire, UK

publish command not working in Rule-Sets

#1 Post by dynamicdave » 11 Jun 2020, 18:16

Hi,
I'm using this command in a Rule-Set...

Publish,weatherStation/reading,'{"node_number":"%sysname%"}'

It works fine in... mega-20200410

But none of the later releases work.

i.e. mega-20200426, mega-20200516 and mega-20200608

Please let me know if there is a more appropriate place to post this issue.

Regards, David.

TD-er
Core team member
Posts: 2790
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: publish command not working in Rule-Sets

#2 Post by TD-er » 11 Jun 2020, 19:42

Make sure your node is connected to the MQTT broker.

Check for example the controller settings like the Controller Client ID.
It has (now)

Code: Select all

%sysname%_%unit%
Along with the "Append Unit Number to hostname" checkbox in the Config tab, it may give a different client ID.

Someone else mentioned this to me yesterday, so that's why these suggestions are so specific.

User avatar
dynamicdave
Normal user
Posts: 219
Joined: 30 Jan 2017, 20:25
Location: Hampshire, UK

Re: publish command not working in Rule-Sets

#3 Post by dynamicdave » 12 Jun 2020, 17:13

I think I've managed to sort out the issue.

I'm using BeeBotte as my remote MQTT broker.

I've found you have to insert the BeeBotte API Token in BOTH the Controller User and Controller Password boxes.

The ESP Easy release dated 20200410 - you only had to enter the token in Controller User box.

Not very secure as you can 'see' the token as cleartext.
ScreenShot099.png
ScreenShot099.png (5.32 KiB) Viewed 739 times

TD-er
Core team member
Posts: 2790
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: publish command not working in Rule-Sets

#4 Post by TD-er » 13 Jun 2020, 11:27

Hmm that's strange.
how long is this token?

User avatar
dynamicdave
Normal user
Posts: 219
Joined: 30 Jan 2017, 20:25
Location: Hampshire, UK

Re: publish command not working in Rule-Sets

#5 Post by dynamicdave » 13 Jun 2020, 12:21

22 characters

e.g. token_MpvmXXXXXXXXXXeX

It includes the word... token_

TD-er
Core team member
Posts: 2790
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: publish command not working in Rule-Sets

#6 Post by TD-er » 13 Jun 2020, 13:21

The only recent change here is to allow 'extended' credentials (more characters)
22 characters is also not close to any logical limit, so it is also not related to a missing trailing zero or something like that.

User avatar
dynamicdave
Normal user
Posts: 219
Joined: 30 Jan 2017, 20:25
Location: Hampshire, UK

Re: publish command not working in Rule-Sets

#7 Post by dynamicdave » 13 Jun 2020, 13:33

It will be interesting to hear if anyone else who uses BeeBotte as their remote MQTT broker has had any problems recently.

Note:
When I use the 'extended' credentials tick-option it seems to corrupt the token in the Controller User box after I do a re-boot.

I'm sure my friend in Boston (who uses Wemos devices and BeeBotte) will be checking this issue out, so
it will be interesting to get his feedback.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests