Formula in MQTT import does not seem to work

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
BertB
Normal user
Posts: 1033
Joined: 25 Apr 2015, 14:39

Formula in MQTT import does not seem to work

#1 Post by BertB » 13 Jun 2020, 22:54

It seems that the formula functuion in MQTT import does not work.
I run:
Build:⋄ 20107 - Mega
System Libraries:⋄ ESP82xx Core 5473656e, NONOS SDK 2.2.2-dev(a58da79), LWIP: 2.1.2 PUYA support
Git Build:⋄ mega-20200608
Plugin Count:⋄ 83 [Normal] [Testing]

on a Wemos.

I expect : %value%/1000 to give a new value divided by a 1000, but that does not happen
mqtt formula 1.PNG
mqtt formula 1.PNG (36.38 KiB) Viewed 643 times
mqtt formula 1.PNG
mqtt formula 1.PNG (36.38 KiB) Viewed 643 times
Attachments
mqtt formula 2.PNG
mqtt formula 2.PNG (34.15 KiB) Viewed 643 times

User avatar
grovkillen
Core team member
Posts: 3606
Joined: 19 Jan 2017, 12:56
Location: Hudiksvall, Sweden
Contact:

Re: Formula in MQTT import does not seem to work

#2 Post by grovkillen » 14 Jun 2020, 05:56

Sounds like a bug.
ESP Easy Flasher [flash tool and wifi setup at flash time]
ESP Easy Webdumper [easy screendumping of your units]
ESP Easy Netscan [find units]
Official shop: https://firstbyte.shop/
Sponsor ESP Easy, we need you :idea: :idea: :idea:

TD-er
Core team member
Posts: 2788
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Formula in MQTT import does not seem to work

#3 Post by TD-er » 14 Jun 2020, 11:21

Yep and I think a similar one has also been reported for another plugin.
Pulse counter maybe?

I guess it may be related to when the call to sendData is made...

BertB
Normal user
Posts: 1033
Joined: 25 Apr 2015, 14:39

Re: Formula in MQTT import does not seem to work

#4 Post by BertB » 14 Jun 2020, 17:21

Okay, good to hear it is under control

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 22 guests