Communication-Serial-Server TX-Enable

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
cbamav
New user
Posts: 3
Joined: 01 Jun 2023, 22:28

Communication-Serial-Server TX-Enable

#1 Post by cbamav » 01 Jun 2023, 22:57

Hi,
i need to communicate with an RS485 Device from my PC over Ser2Net to an ABB Aurora Inverter. So i pluged a TTL to RS485 board on my ESP32. The problem is the TX-Enable Pin on the RS485 board.
How can i set thies signal from my ESP32. On a old Screenshot from version 20210223 the option TX-Enable is pressent. But on the current version this option is not available. But i need the new version because i have 2 devices and this is possible again with the new version...
Can someone tell me where this option is in the current version or what other options there are for generating the TX-Enable signal?


Thanks very much
Attachments
TTL_2_RS485_Board
TTL_2_RS485_Board
TTL2RS485.png (228.74 KiB) Viewed 2496 times
current version
current version
esp2.png (73.04 KiB) Viewed 2496 times
old version from 20210223
old version from 20210223
TX Enable.png (98.59 KiB) Viewed 2496 times

TD-er
Core team member
Posts: 8981
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Communication-Serial-Server TX-Enable

#2 Post by TD-er » 01 Jun 2023, 23:08

With MAX485 chips you typically can connect the DE/RE pins with the TX.
The DE and /RE are eachother's inverse and this way the chip is set to "sending" mode when you try to send a bit.

cbamav
New user
Posts: 3
Joined: 01 Jun 2023, 22:28

Re: Communication-Serial-Server TX-Enable

#3 Post by cbamav » 02 Jun 2023, 16:24

i will try it.
my concern is that if I send a 0/low over TX the line will be released on the RS485 when RE/DE go low and some weird signal will be generated.

TD-er
Core team member
Posts: 8981
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: Communication-Serial-Server TX-Enable

#4 Post by TD-er » 02 Jun 2023, 19:40

It is really not that uncommon to wire it like this.

Image
Source

cbamav
New user
Posts: 3
Joined: 01 Jun 2023, 22:28

Re: Communication-Serial-Server TX-Enable

#5 Post by cbamav » 03 Jun 2023, 20:51

i don`t find my Problem. i started from this pcture:
https://b2600043.smushcdn.com/2600043/w ... p=1&webp=1
my first stap was to remove the RS485 bard and made a wire from RX1 to TX2 and a 2nd from TX1 to RX2. i configured my ESP32, opend 2 terminals an everything was working => ESP-Config is ok
my next step was adding the 2 RS485 boards again and i put the DE/RE Line to the TX Pins. -> No communication
now a put the DE/RE Line on the first RS485 to GND and the 2nd to 3.3 Volt to geht a Communication in one direction, but it was still not working.... I cant find my problem.

but back to the first question. is the Option "TX Enable PIN" no longer available?
i think this is necessary if i sand a 0-bit. The De/RE Line should stay on hight so it is not possible to conntex DE/RE to the TX Pin
Attachments
PXL_20230603_184828261.jpg
PXL_20230603_184828261.jpg (1.83 MiB) Viewed 2456 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest