RFID Wiegand issue with newer Builds after 03_2018

Moderators: grovkillen, Stuntteam, TD-er

Post Reply
Message
Author
laserrichi
Normal user
Posts: 3
Joined: 05 Apr 2019, 18:23

RFID Wiegand issue with newer Builds after 03_2018

#1 Post by laserrichi » 05 Apr 2019, 18:39

Hi,
i have an issue with Wiegand Reader that i use.
It works with ESPEasy Build Versions from March 2018. But not real 100% stable but it works after second Code input.

Newer Builds works very bad or not. The latest Builds with Core 2.41 2.42 or 2.60 are very bad.

I can rule out hardware errors, and I measured the timings with an Oscilloscope, the Input levels of 5V and Levelshifter to 3.3V are perfect.

laserrichi
Normal user
Posts: 3
Joined: 05 Apr 2019, 18:23

Re: RFID Wiegand issue with newer Builds after 03_2018

#2 Post by laserrichi » 07 May 2019, 17:15

no any idea ? I think it is Timing, newer Versions of espeasy have many more features, and the sampling rate of the input ports are lower ?

If i Debug the reader Messages i see:
EspEasy: RFID : reset bits: 50 (bits are different if not work)

and if its work i see
EspEasy: RFID : Tag: 4566 Bits: 26

My Reader send wiegand with 26Bits

ChrisX
Normal user
Posts: 2
Joined: 04 Jun 2019, 07:33

Re: RFID Wiegand issue with newer Builds after 03_2018

#3 Post by ChrisX » 04 Jun 2019, 07:45

hm i also have problems .. i get no Tags ... You have a old version to flash?

laserrichi
Normal user
Posts: 3
Joined: 05 Apr 2019, 18:23

Re: RFID Wiegand issue with newer Builds after 03_2018

#4 Post by laserrichi » 12 Aug 2019, 21:37

i use this Version https://github.com/letscontrolit/ESPEas ... a-20180319
Not tested the latest versions, with different cores.
which card reader are you using?

TD-er
Core team member
Posts: 1475
Joined: 01 Sep 2017, 22:13
Location: the Netherlands
Contact:

Re: RFID Wiegand issue with newer Builds after 03_2018

#5 Post by TD-er » 13 Aug 2019, 00:04

If you're having reports like these, you better create an issue for it on GitHub.
I made one for this issue: https://github.com/letscontrolit/ESPEasy/issues/2544

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 7 guests